LINUX.ORG.RU

apt-get vs aptitude

 , ,


1

3

Обновлял тут debian с 7 на 8 на днях, поменял в sources.list версию на jessie, все как положено. При обновлении aptitude выдал огромное количество конфликтов, а apt-get обновил и ничего не сказал. Почему так может быть?

Перемещено JB из talks

емнимс dist-upgrade в аптитуде объявлено deprecated, и рекомендовано использовать full-upgrade.

Алсо, 8 с сустемд не нужен.

svr4 ()
Ответ на: комментарий от svr4

это ты не нужен без системд, скоро все туда переползут и остануться одни сектанты патриковы без менеджеров пакетов

amorpher ★★★★★ ()

Обычное дело. У aptitude свои алгоритмы, по которым он по каждому чиху норовит снести половину системы даже если apt-get в этих же самых ситуациях ничего подобного делать не пытается. Поэтому я юзаю последний.

saahriktu ★★★★★ ()
Ответ на: комментарий от amorpher

скоро все туда переползут и остануться одни сектанты патриковы без менеджеров пакетов

Не скоро, а уже

Kaschenko ()

aptitude пытается разрулить зависимости, в то время как apt-get в таких случаях просто удаляет старый пакет.

aidaho ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.