LINUX.ORG.RU

Ввод русских символов в играх (?)

 , , , ,


0

1

Внезапно отвалился ввод русских символов в играх (Minecraft) и в Steam Overlay. Не понимаю, что произошло. Менял дефолтную раскладку разве что в апплете блокировки (light-locker), но вернул всё назад. Всё равно не работает.

При этом копипаст русских символов в окна чата в играх работает, да и вообще никаких проблем.

xfce, manjaro (на арче основан) 0.8.13.

$ cat /etc/X11/xorg.conf.d/00-keyboard.conf Section «InputClass» Identifier «system-keyboard» MatchIsKeyboard «on» Option «XkbLayout» «us,ru» Option «XkbModel» «pc105» Option «XkbVariant» "," Option «XkbOptions» «terminate:ctrl_alt_bksp,grp:alt_shift_toggle» EndSection $ locale LANG=ru_UA.utf8 LC_CTYPE=«ru_UA.utf8» LC_NUMERIC=«ru_UA.utf8» LC_TIME=«ru_UA.utf8» LC_COLLATE=«ru_UA.utf8» LC_MONETARY=«ru_UA.utf8» LC_MESSAGES=«ru_UA.utf8» LC_PAPER=«ru_UA.utf8» LC_NAME=«ru_UA.utf8» LC_ADDRESS=«ru_UA.utf8» LC_TELEPHONE=«ru_UA.utf8» LC_MEASUREMENT=«ru_UA.utf8» LC_IDENTIFICATION=«ru_UA.utf8» LC_ALL= $ locale -a C en_US.utf8 POSIX ru_UA.utf8

Кстати, у меня такая же проблема со стимовским чатом (arch linux). Как вариант только писать транслитом.

$ cat /etc/X11/xorg.conf.d/00-keyboard.conf Section «InputClass» Identifier «system-keyboard» MatchIsKeyboard «on» Option «XkbLayout» «us,ru» Option «XkbModel» «pc105» Option «XkbVariant» "," Option «XkbOptions» «terminate:ctrl_alt_bksp,grp:alt_shift_toggle» EndSection $ locale LANG=ru_UA.utf8 LC_CTYPE=«ru_UA.utf8» LC_NUMERIC=«ru_UA.utf8» LC_TIME=«ru_UA.utf8» LC_COLLATE=«ru_UA.utf8» LC_MONETARY=«ru_UA.utf8» LC_MESSAGES=«ru_UA.utf8» LC_PAPER=«ru_UA.utf8» LC_NAME=«ru_UA.utf8» LC_ADDRESS=«ru_UA.utf8» LC_TELEPHONE=«ru_UA.utf8» LC_MEASUREMENT=«ru_UA.utf8» LC_IDENTIFICATION=«ru_UA.utf8» LC_ALL= $ locale -a C en_US.utf8 POSIX ru_UA.utf8

Это сложно будет нормально прочитать, советую обернуть в лоркод

sudopacman ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.