LINUX.ORG.RU

[Debian]Локаль


0

0

При монтировании флешек, дисков и.т.д вместо русских букв показываеться знаки вопроса, гугль ничего толкового не выдает dpkg-reconfigure locales не помогает.

> locale
LANG=ru_RU
LC_CTYPE="ru_RU"
LC_NUMERIC="ru_RU"
LC_TIME="ru_RU"
LC_COLLATE="ru_RU"
LC_MONETARY="ru_RU"
LC_MESSAGES="ru_RU"
LC_PAPER="ru_RU"
LC_NAME="ru_RU"
LC_ADDRESS="ru_RU"
LC_TELEPHONE="ru_RU"
LC_MEASUREMENT="ru_RU"
LC_IDENTIFICATION="ru_RU"
LC_ALL=

Re: [Debian]Локаль

А чё только ru_RU, а не ru_RU.UTF-8 (или что там)?

Как флешки монтируешь? mount -t vfat -o rw,iocharset=локаль /dev/sda1 /mnt/flash Так? (В случае с utf8 надо заменять iocharset=локаль на utf8 просто).

Round ★★ ()

Re: [Debian]Локаль

В настройках HAL нужно написаь чтобы vfat монтировался :

radws% cat /etc/hal/fdi/policy/codepage.fdi 
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
<device>
<match key="volume.fstype" string="vfat">
<merge key="volume.policy.mount_option.iocharset=utf-8" type="bool">true</merge>
<merge key="volume.policy.mount_option.codepage=866" type="bool">true</merge>
</match>
</device>
</deviceinfo>%

wfrr ★★☆ ()
Ответ на: Re: [Debian]Локаль от wfrr

Re: [Debian]Локаль

> <merge key="volume.policy.mount_option.iocharset=utf-8" type="bool">true</merge>

iocharset=utf-8 для вфата не очень. ФС становится кейс-сенситив. Есть отдельная опция, "utf-8", при этом иочарсет прописывать не надо.

Round ★★ ()
Ответ на: Re: [Debian]Локаль от Round

Re: [Debian]Локаль

>ФС становится кейс-сенситив.

С эти проблем не возникало.

wfrr ★★☆ ()
Ответ на: Re: [Debian]Локаль от wfrr

Re: [Debian]Локаль

Не помогает =(

sudo mount -t vfat -o rw,utf8 /dev/sdf1 /mnt/flash - вот так монтируеться нормально, но вручную каждый раз монтировать не хочеться, я писать скрипт - костыль

ZZaiatSS ★★ ()
Ответ на: Re: [Debian]Локаль от ZZaiatSS

Re: [Debian]Локаль

>Не помогает =(

/etc/hal/fdi/policy/codepage.fdi поправил?

Кто автомонтирует? Гном? Кеды? Рекомендую выбросить их автомаунтилку и покапать в сторону pmount - гибкая штука.

Round ★★ ()
Ответ на: Re: [Debian]Локаль от wfrr

Re: [Debian]Локаль

После правки конфиги hal я куищил. Да и в твоем конфиге вроде тоже прописано UTF-8.

Извините за ламаерстов - с локалью дело имею впервые, с халом тоже

ZZaiatSS ★★ ()
Ответ на: Re: [Debian]Локаль от Round

Re: [Debian]Локаль

Монтирует гном. /etc/hal/fdi/policy/codepage.fdi у меня вообще нету, правил я /etc/hal/fdi/policy/preferences.fdi:

-> cat /etc/hal/fdi/policy/preferences.fdi <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<!-- Some examples how to use hal fdi files for system preferences You can either uncomment the examples here or put them in a seperate .fdi file. --> <deviceinfo version="0.2"> <!-- The following shows how to hint gnome-volume-manager and other programs that honor the storage.automount_enabled_hint to not mount non-removable media. --> <!-- <device> <match key="volume.fstype" string="vfat"> <merge key="volume.policy.mount_option.iocharset=utf-8" type="bool">true</merge> <merge key="volume.policy.mount_option.codepage=866" type="bool">true</merge> </match> </device> --> </deviceinfo>

ZZaiatSS ★★ ()
Ответ на: Re: [Debian]Локаль от ZZaiatSS

Re: [Debian]Локаль

-> cat /etc/hal/fdi/policy/preferences.fdi
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<!--
Some examples how to use hal fdi files for system preferences
You can either uncomment the examples here or put them in a seperate .fdi
file.
-->
<deviceinfo version="0.2">
<!--
The following shows how to hint gnome-volume-manager and other programs
that honor the storage.automount_enabled_hint to not mount non-removable
media.
-->
<!--
<device>
<match key="volume.fstype" string="vfat">
<merge key="volume.policy.mount_option.iocharset=utf-8" type="bool">true</merge>
<merge key="volume.policy.mount_option.codepage=866" type="bool">true</merge>
</match>
</device>
-->
</deviceinfo>


вот так правильнее

ZZaiatSS ★★ ()
Ответ на: Re: [Debian]Локаль от ZZaiatSS

Re: [Debian]Локаль

<merge key="volume.policy.mount_option.iocharset=utf-8" type="bool">true</merge> 
<merge key="volume.policy.mount_option.codepage=866" type="bool">true</merge> 

на

<merge key="volume.policy.mount_option.utf-8" type="bool">true</merge> 

Хотя это от фонаря.

wfrr ★★☆ ()
Ответ на: Re: [Debian]Локаль от wfrr

Re: [Debian]Локаль

Создал файл /etc/hal/fdi/policy/codepage.fdi запихнул это все туда, но все равно не пашет :'(

ZZaiatSS ★★ ()
Ответ на: Re: [Debian]Локаль от ZZaiatSS

Re: [Debian]Локаль

http://wiki.archlinux.org/index.php/%D0%9C%D0%BE%D0%BD%D1%82%D0%B8%D1%80%D0%B...

для Ъ:

Для монтирования внешних носителей в Gnome используется gnome-volume-manager. Но при его использовании я заметил, что внешние носители монтируются без указания правильной кодировки символов файловой системы, что приводит к отображению знаков вопросов вместо букв в именах файлов.

После долгих разбирательств с hal и udev оказалось, что во всем "виноват", все-таки, gnome-volume-manager, который напрочь игнорирует fdi-правила hal. Но в то же время gnome-volume-manager позволяет указать опции монтирования через gconf-editor.

Нужный ключик для vfat находится в базе gconf по следующему адресу: /system/storage/default_options/vfat. Просто добавьте к имеющимся опцию "iocharset=utf8" (если у вас локаль ru_RU.UTF-8, или другое значение, если у вас другая локаль).

Nao ★★★★★ ()
Ответ на: Re: [Debian]Локаль от Nao

Re: [Debian]Локаль

Спасибо тебе огромное! Все заработало. Очень тебе благодарен

ZZaiatSS ★★ ()
Ответ на: Re: [Debian]Локаль от Nao

Re^2: [Debian]Локаль

> Нужный ключик для vfat находится в базе gconf по следующему адресу: /system/storage/default_options/vfat. Просто добавьте к имеющимся опцию "iocharset=utf8" (если у вас локаль ru_RU.UTF-8, или другое значение, если у вас другая локаль).

Что-то мне это напоминает: "Чтобы удалить вкладку DFS из проводника, что позволит предотвратить изменение свойств локальных сетевых ресурсов DFS пользователями, выполните следующее: Перейдите в подраздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PoliciesExplorer и создайте ключ типа DWORD NoDFSTab со значением равным 1 "

Пора Gnome Tweaker писать :)

gaa ★★ ()
Ответ на: Re: [Debian]Локаль от Nao

В костреша погань всю сволоку в конец...

> После долгих разбирательств с hal и udev оказалось, что во всем "виноват", все-таки, gnome-volume-manager, который напрочь игнорирует fdi-правила hal.

Ептыть, но почему каждая [censored] поделка думает, что она -- самая умная? Что у пользователя есть время лично ей вписывать настройки, которые уже где-то написаны?

> Но в то же время gnome-volume-manager позволяет указать опции монтирования через gconf-editor.

Да, реестр и HIG, похоже, окончательно повредили мОзги товарищу Де Иказе и его соратникам. Пора таки их отправлять на трудотерапию. Поработают на лесоповале с пару годиков -- авось попустит.

Dselect ★★★ ()
Ответ на: Re: [Debian]Локаль от Round

Ну когда же оно сдохнет?

> mount -t vfat -o rw,iocharset=локаль /dev/sda1 /mnt/flash

А чем ext2 не устраивает? Ведь fat -- это куча геморроя (см. этот тред).

P.S.

Интересно, закопают ли эту чудо-"ФС", когда флешки станут (сильно) больше, чем 4Gb? Или придумают очередную подпорку?

Dselect ★★★ ()
Ответ на: Ну когда же оно сдохнет? от Dselect

Re: Ну когда же оно сдохнет?

А на винде как ext2? Это же надо на каждый компьютер в который хочешь вставить флеху ставить драйвер. А атк у меня на флешке 2 раздела - 700 мб ext2 и 200 мб FAT

ZZaiatSS ★★ ()
Ответ на: Re: Re^2: [Debian]Локаль от ZZaiatSS

Re^4: [Debian]Локаль

> Так твикер уже написали. На лоре где-то ссылка ходила

Не твикер, а пока только чистильщик рее^W gconf-а :)

gaa ★★ ()
Ответ на: Re: Ну когда же оно сдохнет? от ZZaiatSS

Re: Ну когда же оно сдохнет?

> А на винде как

А что я там забыл?

> Это же надо на каждый компьютер в который хочешь вставить флеху ставить драйвер.

На флешку залит live дистрибутив (FINNIX). И если вдруг пришлось пользоваться компьютером, где не установлена ОС, можно спокойно с неё загрузиться.

Dselect ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.