LINUX.ORG.RU

phppgadmin под Nginx не запускается

 , ,


0

1

Делаю виртуальный Ubuntu server 15.04. Веб-сервер - Nginx, язык программирования - php, база данных - postgresql (установлена в процессе создания сервера Ubuntu на Esxi).

Затем установил PhpPgAdmin.

В интернете пишут, что после установки phppgadmin надо подключить файл конфигурации phppgadmin к веб-серверу. Согласно вычитанным мною рекомендациям я сделал следующее:

1. Создал каталоги /var/www/phppgadmin.examlpe.com/html

2. В .../html поместил симлинк 'phppgadmin' на каталог /usr/share/phppgadmin

3. Создал отдельный файл /etc/nginx/sites-available/phppgadmin.example.com где в серверном блоке указал root /var/www/phppgadmin.examlpe.com/html/phppgadmin и server_name phppgadmin.example.com

4 В /etc/nginx/sites-enabled создал симлинк 'phppgadmin.example.com' на /etc/nginx/sites-available/phppgadmin.example.com

5. В файле /etc/hosts добавил строчку IP_сервера phppgadmin.example.com

Увы, набирая в браузере http://phppgadmin.example.com, получаю сообщение «страница недоступна».

Что я сделал не так?

Создал каталоги /var/www/phppgadmin.examlpe.com/html

examlpe

вот, вот где ошибка-то, вот! базарю!

если честно, то если ты не показываешь конфиги, то можно так и продолжать гадать по кофейной гуще. выкладывай конфиги. все.

Spoofing ★★★★★ ()
Ответ на: комментарий от Spoofing

Ну, в конфиги-то я, собственно, не лазил, могу показать только файл /etc/nginx/sites-available/phppgadmin.aldorgol.com

root /var/www/phppgadmin.aldorgol.com/html/phppgadmin;

#access_log /var/log/hginx/access.log; #error_log /var/log/nginx/error.log;

# Add index.php to the list if you are using PHP index index.php index.html index.htm index.nginx-debian.html;

server_name phppgadmin.aldorgol.com http://www.phppgadmin.aldorgol.com;

location / { # First attempt to serve request as file, then # as directory, then fall back to displaying a 404. try_files $uri $uri/ =404; }

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000 # location ~ \.php$ { # include snippets/fastcgi-php.conf; # # # With php5-cgi alone: # fastcgi_pass 127.0.0.1:9000; # # With php5-fpm: try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass unix:/var/run/php5-fpm.sock; fastcgi_param SCRIPT_FILENAME /var/www/html/phppgadmin.aldorgol.com/html/postgres$fastcgi_script_name; include /etc/nginx/fastcgi_params; }

# deny access to .htaccess files, if Apache's document root # concurs with nginx's one # #location ~ /\.ht { # deny all; #} }

то, что нужно?

aldorgol ()

а теперь еще раз, но с нормальным форматированием. Ты сам разве не видишь какая каша из текст у тебя получилась?

JB ★★★★★ ()

судя по всему тебе нужно не решить имеющуюся проблему, а лучше чтобы просто сделали за тебя. окей.

  server {
    listen 80 default_server;
    server_name phppgadmin.aldorgol.com;

    index index.html index.htm index.php;
    root /var/www;

    location ~ \.php$ {
      try_files $uri =404;

      fastcgi_pass unix:/var/run/php-fpm.sock;

      include fastcgi.conf;
    }
  }

вот простой и рабочий блок server с php для nginx.conf, теперь просто в /var/www положи этот самый phppgadmin.

Spoofing ★★★★★ ()

получаю сообщение «страница недоступна».

Скриншот страницы вместе со строкой адреса покажи.

d2 ()
Ответ на: комментарий от JB

Как видишь мой вопрос из прошлой темы После установки phppgadmin на ubuntu в браузере вместо страницы nginx открывается страница apache (комментарий) вполне актуален, и не несет в себе каких либо 4.2.
ТС явно не в курсе про php-fpm, а судя по количеству одинаковых тем возможно даже неадекватен.

TDrive ★★★★★ ()

Разбил на абзацы

#access_log /var/log/hginx/access.log; #error_log /var/log/nginx/error.log;

# Add index.php to the list if you are using PHP index index.php index.html index.htm index.nginx-debian.html;

server_name phppgadmin.aldorgol.com http://www.phppgadmin.aldorgol.com;

location / { # First attempt to serve request as file, then # as directory, then fall back to displaying a 404. try_files $uri $uri/ =404; }

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

# location ~ \.php$ { # include snippets/fastcgi-php.conf;

# # # With php5-cgi alone:

# fastcgi_pass 127.0.0.1:9000;

# # With php5-fpm:

try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$;

fastcgi_pass unix:/var/run/php5-fpm.sock;

fastcgi_param SCRIPT_FILENAME /var/www/html/phppgadmin.aldorgol.com/html/postgres$fastcgi_script_name; include /etc/nginx/fastcgi_params; }

# deny access to .htaccess files, if Apache's document root

# concurs with nginx's one

# #location ~ /\.ht { # deny all; #} }

aldorgol ()
Ответ на: комментарий от JB

Пардон, разбил на абзацы (старый вариант)

#access_log /var/log/hginx/access.log; #error_log /var/log/nginx/error.log;

# Add index.php to the list if you are using PHP index index.php index.html index.htm index.nginx-debian.html;

server_name phppgadmin.aldorgol.com http://www.phppgadmin.aldorgol.com;

location / { # First attempt to serve request as file, then # as directory, then fall back to displaying a 404. try_files $uri $uri/ =404; }

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

# location ~ \.php$ { # include snippets/fastcgi-php.conf;

# # # With php5-cgi alone:

# fastcgi_pass 127.0.0.1:9000;

# # With php5-fpm:

try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$;

fastcgi_pass unix:/var/run/php5-fpm.sock;

fastcgi_param SCRIPT_FILENAME /var/www/html/phppgadmin.aldorgol.com/html/postgres$fastcgi_script_name; include /etc/nginx/fastcgi_params; }

# deny access to .htaccess files, if Apache's document root

# concurs with nginx's one

# #location ~ /\.ht { # deny all; #} }

aldorgol ()
Ответ на: комментарий от Spoofing

То есть, для того, чтобы php заработало, достаточно было добавить строчку

include fastcgi.conf;

Симлинк можно было положить прямо в /var/www, новый хост phppgadmin.aldorgol.com сделать сервером по умолчанию (default_server), положить симлинк на него в /etc/nginx/sites-enabled, а ссылку на /etc/nginx/sites-available/default оттуда удалить и всё бы уже заработало?

Правда, плёвое было дело (если знать, как делать)

Спасибо!

А, вот ещё, вроде бы, был вариант в /etc/nginx/sites-available/default добавить отдельный location. Теперь, задним числом, прикидываю, каким можно было сделать этот location:

location = /phppgadmin {

root /usr/share/phppgadmin;

}

Тогда никаких симлинков можно было бы и не делать, правильно я понимаю?

aldorgol ()
Ответ на: комментарий от erzent

Я ничего не переделывал. Я зашёл сейчас сюда, увидел, что мне тут что-то написали, вот, я и отвечаю людям. А, заодно, советуюсь, нельзя ли было сделать проще, рациональнее, только и всего

aldorgol ()
Ответ на: комментарий от Amet13

Просто каждый следующий этап я выделил в отдельную тему. Просто хотелось быстрее получить ответ

aldorgol ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.