LINUX.ORG.RU

Firefox: буква «м» сливается с другими буквами - как побороть?

 ,


0

3

Здравствуйте, господа. Установлен Debian Jessie + KDE + Firefox 38.0.1 (Firefox с настройками шрифтов по умолчанию). С целью облагородить шрифты был установлен Infinality со следующими настройками:

sudo /etc/fonts/infinality/infctl.sh setstyle
Select a style:
1) debug       3) linux       5) osx2        7) win98
2) infinality  4) osx         6) win7        8) winxp
#? 6
conf.d -> styles.conf.avail/win7
cat /etc/profile.d/infinality-settings.sh | grep USE_STYLE=
USE_STYLE="WINDOWS7"

Также были скопированы шрифты из Windows 8.1 (C:\Windows\Fonts) в Debian (/usr/share/fonts/truetype/ttf-windows) и настроено dpkg-reconfigure fontconfig-config -> Autohinter -> Всегда -> Нет.

Всё устраивает за исключением буквы «м» в шрифте Tahoma, которая так и норовит слиться с другими рядом стоящими буквами:

Скриншот (это со страницы ВКонтакте, каюсь)

Подскажите, пожалуйста, возможно ли каким-либо образом устранить этот неприятный эффект в Firefox без увеличения размеров или смены шрифта?

P.S. Если это важно, то рабочее разрешение экрана 1920x1200.


Проект Infinality уже не поддерживается разработчиком, весь энтузиазм теперь сосредоточен https://github.com/bohoomil/fontconfig-ultimate

Использую наработки infinality еще с 2011 года, и хочу сказать, что там рендеринг заточен под шрифты из шindoшs 7 (ты же скопировал с 8, что есть разница).

Методом проб и ошибок, я скомбинировал идеальную комбинацию шрифтов (из 7,8) которые отображаются лучше своих предшественников. Но на данный момент использую только free-шрифты, чего желаю и другим.

awesomenickname ★★★★★ ()

Можно подкрутить ему настройки хинтинга для разных размеров, например как для DejaVu Sans Mono:

cat /etc/fonts/conf.d/20-unhint-small-dejavu-sans-mono.conf
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
<fontconfig>
  <!--  /etc/fonts/conf.d/20-unhint-small-dejavu-sans-mono.conf

        Disable hinting manually at smaller sizes (< 8ppem)
        This is a copy of the Bistream Vera fonts fonts rule, as DejaVu is
        derived from Vera.

        The Bistream Vera fonts have GASP entries suggesting that hinting be
        disabled below 8 ppem, but FreeType ignores those, preferring to use
        the data found in the instructed hints. The initial Vera release
        didn't include the right instructions in the 'prep' table.
 -->
  <match target="font">
    <test name="family">
      <string>DejaVu Sans Mono</string>
    </test>
    <test compare="less" name="pixelsize">
      <double>7.5</double>
    </test>
    <edit name="hinting">
      <bool>false</bool>
    </edit>
  </match>
</fontconfig>

Состряпать что-то такое для Tahoma и положить в ~/.config/fontconfig/conf.d/. И, насколько я знаю, Tahoma для печати делался, для экранов Verdana, может у него хинтинг получше будет.

mamboo ★★ ()

Решением оказалось выполнение следующей команды:

rm -f /etc/fonts/infinality/styles.conf.avail/win7/{20-aliases-default-win.conf,30-non-latin-inf-win.conf,50-base-rendering-win7-winxp.conf,60-group-tt-fonts.conf}

Sferg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.