LINUX.ORG.RU

При сборке rpm пакета из src пакета ругань

 ,


0

1

Добрый день.

*** CentOS 6.6 ***
Пытаюсь собрать rpm пакет из src пакета proftpd-1.3.4d-1.el6.src.rpm

При сборке

rpmbuild -ba proftpd.spec
Получаю ошибку:
error: Failed build dependencies:
        /usr/include/tcpd.h is needed by proftpd-1.3.4d-1.el6.x86_64

tcp_wrappers - установлен, версия 7.6, но файла /usr/include/tcpd.h физически нет.

Подскажите пожалуйста в чем может быть дело?

Спасибо.

bash-4.2# yum whatprovides /usr/include/tcpd.h
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos-mirror.rbc.ru
 * extras: mirrors-ru.go-parts.com
 * updates: centos-mirror.rbc.ru
tcp_wrappers-devel-7.6-77.el7.i686 : Development libraries and headers for tcp_wrappers
Repo        : base
Matched from:
Filename    : /usr/include/tcpd.h

tcp_wrappers-devel

melkor217 ★★★★★ ()
bash-4.2# stat  /usr/include/tcpd.h
stat: cannot stat ‘/usr/include/tcpd.h’: No such file or directory
bash-4.2# yum install tcp_wrappers-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

....

bash-4.2# stat  /usr/include/tcpd.h
  File: ‘/usr/include/tcpd.h’
  Size: 11760           Blocks: 24         IO Block: 4096   regular file
Device: 8e20b601h/2384508417d   Inode: 524305      Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2014-06-10 08:41:51.000000000 +0400
Modify: 2014-06-10 08:41:51.000000000 +0400
Change: 2015-04-08 16:45:22.812783927 +0300
 Birth: -

melkor217 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.