LINUX.ORG.RU

Сборка PS3Xport на ubuntu 10

 


0

1

Скачал zip с github. Распаковал. Запускаю autogen:

$ ./autogen.sh 
Running aclocal...
configure.ac:4: error: Autoconf version 2.66 or higher is required
configure.ac:4: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
aclocal: autom4te failed with exit status: 63
А в build_loop.sh вообще упоминается «ppu-gcc». В README сказано, что утилита собирается классической триадой (./configure && make && make install), но я не могу получить configure-файла. Помогите со сборкой. Я раньше не сталкивался с такими ситуациями (на этой же машине собирал ffmpeg и transmission из исходников)

★★

Ответ на: комментарий от sT331h0rs3

Да, версия выше.

Отсюда, собственно, вопрос:

Первое: Смогу-ли я собрать программу на lucid со старым Autoconf?

И воторое: как выяснить, с какими ключами собрать эту утилиту под разные архитектуры (x86 и x64) на одной ОС? Я знаю что сборка под чужую архитектуру возможна, но я ни разу такого не делал.

zzdnx ★★ ()
Ответ на: Да, версия выше. от zzdnx

Смогу-ли я собрать программу на lucid со старым Autoconf?

Я в третий раз процитирую один и тот же ответ:

configure.ac:4: error: Autoconf version 2.66 or higher is required

Нет, не сможешь. И с 2.65 не сможешь. Только с 2.66 и больше.

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от SevikL

Первое не катит, так как с обновлениями я получу больше геммороя чем при установке новой ОС с ноля. Новую ОС ставить не мнее плохой вариант - я несколько лет пилил под себя текущий DE и уже пробовал переносить его настройки на новые ОС. Результаты более чем паршивы. Виртуалки - да, можно, но мне будет тяжело разворачивать их на столь малом объёме оператики.

zzdnx ★★ ()
Ответ на: комментарий от sT331h0rs3

Большое спасибо за терпение.

Я как-то не сразу заметил разницу версий. Каюсь, это было глупо.

zzdnx ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.