LINUX.ORG.RU

Не могу найти причину зависания на «waiting for uevents to be processed».

 


0

1

Собрал gentoo-sources-3.17.1-r1 как положено используя конфиг (прошлой) работающей системы на этом же железе.

Картинка зависает на этапе загрузки на пункте «waiting for uevents to be processed..». Именно картинка, потому что по ssh можно зайти.
Ждать смысла не имеет, потому что это именно зависание картинки, но я ждал с 10 минут.

Пересобрал udev, udev-init-scripts, openrc, coreutils, binutils, сделал python-updater, perl-cleaner и все остальные кишки. revdep-rebuild пуст, все конфиги обновлены (etc-update).

Загрузчики не использую, гружу (как прошлую, с клоном конфига работающей системы) через UEFI.

Из фреймбуферов в конфиге стоит только:

CONFIG_FB_EFI=y
что прекрасно работало, иксы стоят с драйвером (xf86-video-ati), но автостарт не включен.

Видео Radeon HD 8670D на A10-6700, хотя это не важно.

В чём может быть причина затыка?


Проблему решил пересборкой udev с USE=«firmware-loader», хотя оно DEPRECATED, ведь грузит используя ядерный метод и/или установкой linux-firmware, которая перезаписала мне firmware собранное с ядром :(

xinu
() автор топика
Ответ на: комментарий от iVS

у меня только

CONFIG_FW_LOADER=y
# CONFIG_FW_LOADER_USER_HELPER_FALLBACK is not set
стоит, нужно будет попробровать поставить user_helper.

xinu
() автор топика
Ответ на: комментарий от xinu

Ага, это на последних ядрах теперь нужен CONFIG_FW_LOADER_USER_HELPER_FALLBACK

iVS ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.