LINUX.ORG.RU

Gentoo. emerge не видит пакеты из оверлея (layman)

 , ,


1

1

Решил поставить себе steam, подключил репозиторий (layman -a steam; layman -S). Обновил метаинформацию (emerge --metadata, emerge --sync, eix-update). Но «emerge -s» не видит пакета «steam-meta» из установленного мной репозитория. Что я делаю не так?

//eix -R прекрасно видит все пакеты

//«source /var/lib/layman/make.conf» в make.conf прописано

Ветка стабильная? А то стим, наверное, в ~arch

equeim ★★ ()
Ответ на: комментарий от equeim

Да, ветка Gentoo стабильная. На всякий случай размаскировал нестабильный steam, но эффекта никакого...

xasecoro ()

а пакет steam-meta вообще существует, ты в этом уверен?

Deleted ()

Что значит «не видит»? Какая именно ошибка?

vurdalak ★★★★★ ()

используй для поиска eix, юный падаван.

Deleted ()

Lifun equeim

Спасибо вам за помощь! Но проблема оказалась в том, что я невнимательный балбес: импорт оверлеев лэймана шел перед определением PORTDIR_OVERLAY. Поменял строчки местами, eix-update и вуаля.

xasecoro ()
Ответ на: комментарий от vurdalak

А никакой ошибки не было - просто не видел ничего и все. После тыкания «emerge --info | grep overlay» на меня снизошло просветление - я portdir_overlay определял после репозиториев лэймана.

xasecoro ()
Ответ на: комментарий от xasecoro

Что значит «просто не видел»? Ты ему пишешь emerge steam-meta, а у тебя компьютер выключается и никакого сообщения не выдаёт?

vurdalak ★★★★★ ()
Ответ на: комментарий от vurdalak

Просто нет пакета в списке и все. Результат аналогичен команде «emerge -s egwegwejigwejge» (или вместо последнего слова имя любого несуществующего пакета)

xasecoro ()
Ответ на: комментарий от xasecoro

При чём тут -s? Когда ты просто набираешь emerge steam-meta, что он говорил? Вот дословно.

vurdalak ★★★★★ ()

eix-sync синхронизирует портажи, eix package ищет package

kma21 ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.