LINUX.ORG.RU

Установка code::blocks в debian

 , ,


0

2

Добрый день. Установил debian первый день, не могу разобраться в пакетах. Нагуглил статью https://packages.debian.org/ru/sid/amd64/codeblocks/download

Установил в /etc/apt/sources.list указаный репозиторий, ввел в консоли «aptitude install codeblocks»

Следующие НОВЫЕ пакеты будут установлены:        
  codeblocks{b} libcodeblocks0{ab} 
0 пакетов обновлено, 2 установлено новых, 0 пакетов отмечено для удаления, и 59 пакетов не обновлено.
Необходимо получить 4 671 kB архивов. После распаковки 14,2 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 codeblocks : Зависит: libwxbase2.8-0 (>= 2.8.12.1) который является виртуальным пакетом.
              Зависит: libwxgtk2.8-0 (>= 2.8.12.1) который является виртуальным пакетом.
              Зависит: codeblocks-common (= 13.12svn9884-1) но установлен 13.12-1 и удерживается.
 libcodeblocks0 : Зависит: libwxbase2.8-0 (>= 2.8.12.1) который является виртуальным пакетом.
                  Зависит: libwxgtk2.8-0 (>= 2.8.12.1) который является виртуальным пакетом.
                  Зависит: binutils (>= 2.14.90.0.7) который является виртуальным пакетом.
Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     codeblocks [Не установлен]                      
2)     libcodeblocks0 [Не установлен]                  

     Оставить следующие зависимости неразрешёнными:    
3)     libcodeblocks0 рекомендует codeblocks           


Принять данное решение? [Y/n/q/?] Y
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 59 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.

Еще попытался вручную скачать .deb файл и установить через dpkg -i codeblocks.deb

dpkg: ошибка при обработке параметра /Загрузки/codeblocks_13.12-3_amd64.deb (--install):
 нет доступа к архиву: Нет такого файла или каталога
При обработке следующих пакетов произошли ошибки:
 /Загрузки/codeblocks_13.12-3_amd64.deb

Что я делаю не так?


Какая у вас версия дебиан? Судя по сообщениям, вы пытаетесь смешать stable и unstable пакеты. Говорят, что это плохо кончается. Вроде как можно смешивать testing и unstable или уж полностью переходить на unstable (sid).

mky ★★★★★ ()

Установил в /etc/apt/sources.list указаный репозиторий

Удали репозиторий из sources.list, который прописал. После выполни:

apt-get update && apt-get install codeblocks

liathit ★★ ()
cd /Загрузки
dpkg -i codeblocks_13.12-3_amd64.deb

или

aptitude update; aptitude upgrade ; aptitude install codeblocks

Dron ★★★★★ ()
Последнее исправление: Dron (всего исправлений: 2)
Ответ на: комментарий от mky

После обновления до testing можно смешать с unstable и тогда уже можно смело подрубать stable. Приоритет у тестинга, а новые/или уже недоступные из stable/unstable.

Хотя аккуратно надо это да. Вон ffmpeg`a больше нема пришлось подрубать stable.

Dron ★★★★★ ()
Ответ на: комментарий от Dron

Хотя аккуратно надо это да

Во, во, с учётом того, что:

Установил debian первый день

Ещё хотел уточнить, а этот:

cd /Загрузки
подразумевает, что у ТС в корне каталог ″Загрузки″, подозрительно ведь?

mky ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.