LINUX.ORG.RU

непонятки с OpenWrt

 


0

1

Хочу добавить нового пользователя ( для того чтобы прогнать пару хело-вордов и просто ознакомится с системой ).

Но оказывается что нету бинарника на adduser/useradd.

идём дальше:

root@OpenWrt:~# opkg search useradd
root@OpenWrt:~# 

Ничего не показывает, но в тоже время:

# opkg list | grep useradd
shadow-useradd - 4.1.5.1-1 - Full version of standard useradd utility. Normally, you would not use this package, since the functionality in BusyBox is more than sufficient.

ладно, учитывая что:

Normally, you would not use this package, since the functionality in BusyBox is more than sufficient

пишем

root@OpenWrt:~# busybox --list | grep user
root@OpenWrt:~# 

Да что такое?

1) Что это за противоречия в репозитории?
2) Как мать его работает opkg search?

Наверное я просто не проникся в филисофию OpenWrt...

★★★★★

Поставь уже shadow-useradd. Или баг зарепорти.

Black_Shadow ★★★★★ ()
Ответ на: комментарий от Black_Shadow

2) search работает так:

а вот нифига:

root@OpenWrt:~# opkg search *useradd*
root@OpenWrt:~# opkg list | grep  useradd
shadow-useradd - 4.1.5.1-1 - Full version of standard useradd utility. Normally, you would not use this package, since the functionality in BusyBox is more than sufficient.
root@OpenWrt:~# 
root@OpenWrt:~# 

Или баг зарепорти.

ок, уговорил.

snaf ★★★★★ ()
Ответ на: комментарий от snaf

Хм. А у тебя какая версия openwrt? У меня:

# cat /etc/openwrt_release 
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Bleeding Edge"
DISTRIB_REVISION="r41762"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="brcm47xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker r41762"
DISTRIB_TAINTS=""

Black_Shadow ★★★★★ ()
Ответ на: комментарий от Black_Shadow

DISTRIB_RELEASE=«Bleeding Edge»

оу, и такой бывает?

root@OpenWrt:/etc# cat /etc/openwrt_release 
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="12.09"
DISTRIB_REVISION="r36088"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Attitude Adjustment 12.09"
# opkg  status opkg | grep -i version
Version: 618-3
snaf ★★★★★ ()
Последнее исправление: snaf (всего исправлений: 1)
Ответ на: комментарий от ii343hbka

ну... как бы я это уже выявил проведя своё раследование.

snaf ★★★★★ ()
Ответ на: комментарий от ii343hbka

меня смутил тот факт что меня направили в бусибокс который лишён данного функционала

snaf ★★★★★ ()
Ответ на: комментарий от snaf

trunk это роллинг, но они выпустили новый rc1, я вам рекомендую именно его устанавливать, т.к. с trunk вы намучаетесь с постоянными обновлениями ядра, а rc1 довольно свежая и должна быть более-менее стабильная.

BB ставить не рекомендую, там старье вообще.

ValdikSS ★★★★★ ()
Ответ на: комментарий от snaf

Нет, это rc. Там почему-то меньше пакетов, чем в танке, так что пришлось добавить репозитарий транка, зато ядро не обновляется каждый день.

Black_Shadow ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.