LINUX.ORG.RU

locale not supported by Xlib


0

0

Читал темы на форуме, вроде всё установлено как надо, а warning есть. Дистрибутив:Gentoo. Суть вопроса: при запуске графических приложений в иксах из консоли они выдают в консоль:

(gimp:25026): Gdk-WARNING **: locale not supported by Xlib

(gimp:25026): Gdk-WARNING **: cannot set locale modifier

Моя локаль: user@gentoo ~ $ locale -a C en_US en_US.utf8 POSIX ru_RU.koi8r ru_RU.uft8 user@gentoo ~ $ locale LANG=ru_RU.UTF8 LC_CTYPE="ru_RU.UTF8" LC_NUMERIC="ru_RU.UTF8" LC_TIME="ru_RU.UTF8" LC_COLLATE="ru_RU.UTF8" LC_MONETARY="ru_RU.UTF8" LC_MESSAGES="ru_RU.UTF8" LC_PAPER="ru_RU.UTF8" LC_NAME="ru_RU.UTF8" LC_ADDRESS="ru_RU.UTF8" LC_TELEPHONE="ru_RU.UTF8" LC_MEASUREMENT="ru_RU.UTF8" LC_IDENTIFICATION="ru_RU.UTF8" LC_ALL=

Что надо подкрутить, чтобы ворнинга не было? Связаны ли с этим крокозябры в Xterm, и если не связаны, то как их испавить?

anonymous

Re: locale not supported by Xlib

Ещё раз листинг локалей:

laser@gentoo ~ $ locale

C

en_US

en_US.utf8

POSIX

ru_RU.koi8r

ru_RU.uft8

ru_RU.utf8

laser@gentoo ~ $ locale

LANG=ru_RU.UTF8

LC_CTYPE="ru_RU.UTF8"

LC_NUMERIC="ru_RU.UTF8"

LC_TIME="ru_RU.UTF8"

LC_COLLATE="ru_RU.UTF8"

LC_MONETARY="ru_RU.UTF8"

LC_MESSAGES="ru_RU.UTF8"

LC_PAPER="ru_RU.UTF8"

LC_NAME="ru_RU.UTF8"

LC_ADDRESS="ru_RU.UTF8"

LC_TELEPHONE="ru_RU.UTF8"

LC_MEASUREMENT="ru_RU.UTF8"

LC_IDENTIFICATION="ru_RU.UTF8"

LC_ALL=

anonymous ()
Ответ на: Re: locale not supported by Xlib от Demetrio

Re: locale not supported by Xlib

В каком? В locale -a ? Вижу. Только маленькими буквами.

anonymous ()
Ответ на: Re: locale not supported by Xlib от anonymous

Re: locale not supported by Xlib

> А как там маленькие буквы в большие переделать тогда?

$ man localedef

ManJak ★★★★★ ()
Ответ на: Re: locale not supported by Xlib от Demetrio

Re: locale not supported by Xlib

Ты не поверишь. user@gentoo ~ $ export LC_ALL="ru_RU.utf8" user@gentoo ~ $ export LANG="ru_RU.utf8" user@gentoo ~ $ firefox No running windows found

(firefox-bin:15422): Gdk-WARNING **: locale not supported by Xlib

(firefox-bin:15422): Gdk-WARNING **: cannot set locale modifiers

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.