LINUX.ORG.RU

Некорректное поведение xfce4-power-manager

 ,


0

2

Проявляется в том, что при подключении адаптера не показывает что идет зарядка. Помогает xfce4-power-manager --restart, но иконка не меняется и если отключить адаптер, то всё равно якобы заряжает. Снова рестарт и пишет что уже работает от батареи. И так по кругу.


Ответ на: арчик? от amorpher

Ага, арчбанг.

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# See logind.conf(5) for details

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
jori ()
Ответ на: комментарий от amorpher

Добавил, перезагрузил на зарядке, иконка сменилась. Но отключил адаптер и всё равно Adaptor is online.

jori ()

Что показывает

acpi -i
И какие пакеты upower установлены? У меня на Debian был похожий глюк - из-за того, что xfce4-power-manager и upower зависели от разных версий libupower-glib.

Programmist11180 ★★★ ()
Ответ на: комментарий от Programmist11180
$ acpi -i
Battery 0: Charging, 45%, 01:32:37 until charged
Battery 0: design capacity 4400 mAh, last full capacity 3464 mAh = 78%

И какие пакеты upower установлены?

Я не знаю как тут посмотреть список зависимостей. Может так

whoneeds xfce4-power-manager
Packages that depend on [xfce4-power-manager]
  None

и

whoneeds upower
error: package 'xfce4-power-manager xfce4-session' was not found
error: could not get information on xfce4-power-manager xfce4-session

Да, устанавливал всё из xfce4-goodies, если это поможет.

jori ()
Ответ на: комментарий от jori

libupower-glib

Поиск показал

$ libupower-glib
bash: libupower-glib: command not found
[an@arch ~]$ locate libupower-glib
/usr/include/libupower-glib
/usr/include/libupower-glib/up-client.h
/usr/include/libupower-glib/up-device.h
/usr/include/libupower-glib/up-history-item.h
/usr/include/libupower-glib/up-stats-item.h
/usr/include/libupower-glib/up-types.h
/usr/include/libupower-glib/up-version.h
/usr/include/libupower-glib/up-wakeup-item.h
/usr/include/libupower-glib/up-wakeups.h
/usr/include/libupower-glib/upower.h
/usr/lib/libupower-glib.so
/usr/lib/libupower-glib.so.2
/usr/lib/libupower-glib.so.2.0.0

/usr/lib/libupower-glib.so.2 и /usr/lib/libupower-glib.so.2.0.0 это одна и та же библиотека?

А по зависимостям

$ pacman -Qi upower
error: could not open file /var/lib/pacman/local/sage-mathematics-6.1.1-2/desc: No such file or directory
Name           : upower
Version        : 0.99.0-2
Description    : Abstraction for enumerating power devices, listening to device events and
                 querying history and statistics
Architecture   : i686
URL            : http://upower.freedesktop.org
Licenses       : GPL
Groups         : None
Provides       : None
Depends On     : systemd-tools  systemd  libusb  polkit  dbus-glib  libimobiledevice
Optional Deps  : None
Required By    : xfce4-power-manager  xfce4-session
Optional For   : None
Conflicts With : None
Replaces       : None
Installed Size : 775.00 KiB
Packager       : Jan de Groot <jgc@archlinux.org>
Build Date     : Mon 14 Apr 2014 06:35:03 PM EEST
Install Date   : Mon 21 Apr 2014 12:20:24 PM EEST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By   : SHA256 Sum

и

$ pacman -Qi xfce4-power-manager
error: could not open file /var/lib/pacman/local/sage-mathematics-6.1.1-2/desc: No such file or directory
Name           : xfce4-power-manager
Version        : 1.2.0-6
Description    : Power manager for Xfce desktop
Architecture   : i686
URL            : http://www.xfce.org/
Licenses       : GPL2
Groups         : xfce4
Provides       : None
Depends On     : xfce4-panel  upower  udisks  libnotify  hicolor-icon-theme
Optional Deps  : None
Required By    : None
Optional For   : None
Conflicts With : None
Replaces       : None
Installed Size : 2282.00 KiB
Packager       : Evangelos Foutras <evangelos@foutrelis.com>
Build Date     : Sun 06 Oct 2013 10:25:57 AM EEST
Install Date   : Mon 21 Apr 2014 11:52:48 PM EEST
Install Reason : Explicitly installed
Install Script : Yes
Validated By   : SHA256 Sum
jori ()
Ответ на: комментарий от jori

/usr/lib/libupower-glib.so.2 скорее всего символическая ссылка на /usr/lib/libupower-glib.so.2.0.0. Можно это узнать через команду file.

Programmist11180 ★★★ ()
25 июля 2014 г.
Ответ на: комментарий от anonymous

upower работает нормально. Значит проблема в xfce4-power-manager. Какой он версии?

Programmist11180 ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.