LINUX.ORG.RU

centos обезумел. не хочет gcc.

 , ,


0

1
$ cat /etc/issue
CentOS release 6.5 (Final)
Kernel \r on an \m

$ uname -i
x86_64

Я просто хотел установить Development Tools.

$ yum groupinstall 'Development Tools'
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * epel: mirror.logol.ru
 * rpmforge: mirror.awanti.com
 * webtatic: nl.repo.webtatic.com
Setting up Group Process
Checking for new repos for mirrors
Warning: Group development does not have any packages.
No packages in any requested group available to install or update

С репами беда? Вроде же нет...

$ yum repolist
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * epel: mirror.logol.ru
 * rpmforge: mirror.awanti.com
 * webtatic: nl.repo.webtatic.com
repo id                     repo name                                                          status
epel                        Extra Packages for Enterprise Linux 6 - x86_64                     10,694
local                       My Awesome Repo                                                         1
rpmforge                    RHEL 6 - RPMforge.net - dag                                         4,678
webtatic                    Webtatic Repository EL6 - x86_64                                      292
repolist: 15,665

Ну может есть уже все? Проверю по gcc.

$ which gcc
/usr/bin/which: no gcc in (/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/alien/bin)

Так как он мне больше нужен, вручную пробую установить gcc

$ yum install gcc
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * epel: mirror.logol.ru
 * rpmforge: mirror.awanti.com
 * webtatic: nl.repo.webtatic.com
Setting up Install Process
No package gcc available.
Error: Nothing to do

Далее yum search по пакетам, пробую установить конкретно gcc-ia64-linux-gnu.x86_64, и дальше - зашедшие в тупик пляски с зависимостями, где не помог rpm -Uvh, yum и даже где-то вычитал что нуна локальный репозиторий создать, тоже не помогло. Что делать, друзья? Кодить хочу, не дает вот.

ia64

кросскомпилятор? для этой архитектуры нет полноценной поддержки.

wakuwaku ★★★★ ()

С репами беда? Вроде же нет...

Вроде же да.

У тебя базовые репозитории не подключены, а ты вместо решения проблемы с бубном пляшешь.

yum repolist all смотри, и rpm -ql centos-release

alpha ★★★★★ ()
Ответ на: комментарий от alpha

Да, Base отключен и дофига прочих. А чегойта так? Раньше такого не было.

drunken_train ()

А ты уверен что тебе нужен кросскомпилятор для итаника? То есть, если нужен, то извини, но не могу не отметить, что ia64 и x86_64 — две очень большие разницы.

dmiceman ★★★★★ ()
Ответ на: комментарий от dmiceman

Меня ввело в заблуждение окончание .x86_64. Да. Но так-то проблема в другом была, так что тему я неправильно озаглавил, не gcc не ставится а репы не работали.

drunken_train ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.