LINUX.ORG.RU

А если убрать «xft:»? Или размер иначе записать: вики арчика говорит размер так писать URxvt.font: xft:monaco:size=10

CrazyAlex25 ★★ ()
Ответ на: комментарий от CrazyAlex25

Если убрать «xft:», то

urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.

А если сделать «=12», то шрифт игнорируется и подцепляется стандартный какой-то.

momo ()

То же самое, в uxterm и urxvt, появилось после модификации fontconfig и хинтинга, хорошо, что кириллица мной не используется нигде кроме браузера, но не приятно.

wakuwaku ★★★★ ()

Xdefaults есть строки

Разве Xdefaults не объявлен давненько уже ненужным? Обсуждали же, что писать нужно в ~/.Xresources

Рекомендую шрифт Tewi, который как терминус (почти), но при этом нормально работает в urxvt.

~/.Xresources:

URxvt*font:              xft:Tewi:regular:size=9
URxvt*imFont:            xft:Tewi:regular:size=9
URxvt*boldFont:          xft:Tewi:regular:size=9
URxvt*italicFont:        xft:Tewi:regular:size=9
URxvt*boldItalicFont:    xft:Tewi:regular:size=9

Скриншот (я люблю помельче): http://i.imgur.com/QTUZimm.png

science ★★☆ ()
Ответ на: комментарий от science

Ты уже предлагал в другом трелей) С .Xresources не работает.

momo ()
Ответ на: комментарий от momo

Ты уже предлагал в другом трелей

Сорри, у меня много чего произошло за это короткое время и я забыл, что ты был ТС того треда.

В общем-то да, после изменения ~/.Xresources (если не ребутаешь машину или меняешь сессию) - нужно делать то, что посоветовал выше wakuwaku.

И еще: чем тебе не подходит Tewi, что ты мучаешься до сих пор с терминусом?

science ★★☆ ()
Ответ на: комментарий от science

Ну оказалось, что не terminus тупит, а I urxvt печатает кириллицу другим шрифтом,. Не очень понравился tewi или к терминусу привык)

momo ()
Ответ на: комментарий от science

Хотя довольно красивый шрифт...приду домой — попробую.

momo ()
Ответ на: комментарий от wakuwaku

В общем, -xrm "*renderFont:true" и eselect fontconfig enable 70-no-bitmaps.conf, теперь наверное кириллица в игрушках отвалилась. :>

wakuwaku ★★★★ ()
Ответ на: комментарий от momo

это параметр для uxterm, можно прописать *renderFont: true в ~/.Xresources.

wakuwaku ★★★★ ()
Ответ на: комментарий от momo

ok, возможно правильней будет URxvt*renderFont: true и xterm*renderFont: true соответственно.

wakuwaku ★★★★ ()
Ответ на: комментарий от momo

Без этого используется какой-то дефолтный шрифт, похожий на dejavu sans.

wakuwaku ★★★★ ()
Последнее исправление: wakuwaku (всего исправлений: 1)
Ответ на: комментарий от wakuwaku

после

eselect fontconfig enable 70-no-bitmaps.conf

вообще терминус пропадает даже в латинице.

momo ()
Ответ на: комментарий от momo
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf *
  [3]   10-scale-bitmap-fonts.conf
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf *
  [12]  20-unhint-small-dejavu-sans.conf *
  [13]  20-unhint-small-dejavu-sans-mono.conf *
  [14]  20-unhint-small-dejavu-serif.conf *
  [15]  20-unhint-small-vera.conf *
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf
  [18]  30-urw-aliases.conf *
  [19]  40-nonlatin.conf *
  [20]  42-luxi-mono.conf *
  [21]  45-latin.conf *
  [22]  49-sansserif.conf *
  [23]  50-user.conf *
  [24]  51-local.conf *
  [25]  52-infinality.conf
  [26]  57-dejavu-sans.conf *
  [27]  57-dejavu-sans-mono.conf *
  [28]  57-dejavu-serif.conf *
  [29]  60-latin.conf *
  [30]  60-liberation.conf
  [31]  62-croscore-arimo.conf *
  [32]  62-croscore-cousine.conf *
  [33]  62-croscore-symbolneu.conf *
  [34]  62-croscore-tinos.conf *
  [35]  65-fonts-persian.conf
  [36]  65-khmer.conf
  [37]  65-nonlatin.conf *
  [38]  66-ja-ipafonts.conf *
  [39]  69-unifont.conf *
  [40]  70-no-bitmaps.conf *
  [41]  70-yes-bitmaps.conf
  [42]  80-delicious.conf *
  [43]  90-synthetic.conf *

сейчас, мне нравится.

wakuwaku ★★★★ ()
Последнее исправление: wakuwaku (всего исправлений: 1)
Ответ на: комментарий от wakuwaku

я не уверен, что терминус у меня работает в urxvt, поэтому пользуюсь xterm, и вообще он имхо удобней в качестве терминала.

wakuwaku ★★★★ ()
Последнее исправление: wakuwaku (всего исправлений: 2)
Ответ на: комментарий от wakuwaku

да, не работает. не знаю, возможно у него другие, не совместимые параметры для указания шрифтов.

wakuwaku ★★★★ ()
Ответ на: комментарий от wakuwaku

Выкину infinality в мусорку, настрою шрифты другим путем. Это все из-за него, видимо.

momo ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.