LINUX.ORG.RU

[debian testing x86_64] [wine 1.2.3] [nouveau] [поиграть] Миссия невыполнима?


0

1

Решил я поставить nouveau вместо блоба, потому что версия 280.13.really.275.28-1, что сейчас в тестинге, у меня люто тормозила. Снёс блоб и xorg.conf, поставил libgl1-mesa-dri-experimental, перезагрузился и увидел, что compiz с прозрачностями заработал без всяких танцев с бубном, к тому же скорость отрисовки приложений просто реактивная (или это кажется после тормозов блоба). Но есть один минус - не запускаются игры под wine, например

sash@sash-linux:~/Games/Rockstar Games/GTA San Andreas$ wine gta_sa
wine: cannot find L"C:\\windows\\system32\\plugplay.exe"
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly
fixme:d3d_caps:select_card_nvidia_mesa Card selection not handled for Mesa Nouveau driver
wine: Unhandled page fault on read access to 0x00000059 at address 0x7e39ef96 (thread 0009), starting debugger...
Но
glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
21183 frames in 5.0 seconds = 4236.520 FPS
21412 frames in 5.0 seconds = 4282.334 FPS
21541 frames in 5.0 seconds = 4307.972 FPS
и
$ glxinfo | grep 'direct rendering'
direct rendering: Yes
полная версия glxinfo здесь

Есть ли возможность заставить игры работать?

P.S. карта GeForce9800gt

ia32-libs установлены

ставить run пакет желания нет

игры не нужны, но иногда хочется развеяться

★★

>тому же скорость отрисовки приложений просто реактивная
сейчас придйет магабакс и будет тебе довазывать что такое невозможно.
Ну в вообще, если выбрал открытые дрова, то желательно ядро и месу иметь как можно свежее.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

я их выбрал скорее «на попробовать» после замораживания блобом интерфейса а-ля 12309, причём фоновые процессы (музыка и т.п.) работали нормально.

ss_ash ★★ ()

Тоже nouveau хочу накатить. Где-то можно почитать список поддерживаемых видеокарт?

f1xmAn ★★★★★ ()

во-первых: про тормоза блоба - откровенная ложь!
инфа 100%
во-вторых: хочешь полноценное 3D - используй блоб!
вариантов нет!
и что это за херня «280.13.really.275.28-1»?
либо то, либо другое!
либо третье - дистр говно!

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

у меня раньше блоб не тормозил, стал тормозить после прихода в обновлениях вот этой самой странной версии - 280.13.really.275.28-1.

ss_ash ★★ ()
Ответ на: комментарий от megabaks

и что это за херня «280.13.really.275.28-1»?

Это способ заставить apt думать, что версия новее. Они сначала сделали 280.13-1, потом откатились на 275.28-1 по каким-то причинам. Но я сей апгрейд не ставил.

franchukroman ★★☆ ()

О том, что хочешь 3D юзай блоб тебе уже сказали. nouveau в данный момент для этого непригодно. Далее следует заметить, что glxgears вообще не разу и ни в одном месте не тест! Хочешь тестов ? Вперед детка!!! Только да для начала нужно таки иногда читать Статус поддержки OpenGL 3.x и 4.x в Mesa

init_6 ★★★★★ ()
Ответ на: комментарий от franchukroman

а я сдуру поставил. Можно и откатиться, но решил попробовать сабж - выяснилось, что он более-менее работает, не работают только игры в wine, скорее всего из-за отсутствия поддержки в драйвере 32 бит.

ss_ash ★★ ()
Ответ на: комментарий от init_6

выяснилось, что компиз со всеми прозрачностями и нетестовые шестерёнки крутит, да и вопрос был не про тесты

ss_ash ★★ ()
Ответ на: комментарий от ss_ash

nouveau хорош, сам на нем. Но не для игр. Для развеятся пробовал игры с прошлого humblebundle.com. Запускались, но что-то посерьезней(wow eve) все вылетает примерное с такой же ошибкой.

ngsupb ()
Ответ на: комментарий от ngsupb

Нативные игры идут, не идут wine игры. Скорее всего из-за того, что в закрытом драйвере есть поддержка 32 битных приложений, а в открытом её, видимо, нет

ss_ash ★★ ()

Решил я поставить nouveau вместо блоба

Ты для этого выбрал не тот дистрибутив 8).

mironov_ivan ★★★★★ ()
Ответ на: комментарий от megabaks

megabaks> во-первых: про тормоза блоба - откровенная ложь!

4.2 2D-ускорение там сделано через жопу.

megabaks> инфа 100%

То есть без подтверждений, понятно.

megabaks> во-вторых: хочешь полноценное 3D - используй Radeon!

fixed

Quasar ★★★★★ ()

У nvidia свой композитный движок и тормоза вызваны чем-то другим. Например, ты для всего OpenGL выставил восьмое сглаживание

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Как проще всего поставить 32-битную Mesa, при условии что 64-битную ты ставил из исходников. CC=«gcc -m32» CXX=«g++ -m32» ./configure --prefix=/home/zenitur . make install запускать надо без прав администратора. Оттуда взять lib и положить в /usr/local/lib32. Можно конечно и без ручной работы, сразу указать чтобы библиотеки устанавливались в /usr/local/lib32. Но у меня ни разу не получилось сделать это без ошибок.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Я в уютненьком пока ещё ничего из исходников не собирал, в данный момент apt не знает только про libflashplayer.so и asoundconf. В принципе, можно поставить 32-битный дистр с pae-ядром, но в мыслях сразу строчка из анекдота: «Боже, опять эти нелепые телодвижения»:)
Если блоб в ближайшие дни не исправят, то займусь компилингом

ss_ash ★★ ()
Ответ на: комментарий от ss_ash

А из чего ты тогда поставил ту месу, я так и не понял? Тогда ищи 32-битные библиотеки там и в ia32-libs.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Из репозитория, 32-битных библиотек в ней нет, ia32-libs установлены.

ss_ash ★★ ()
Ответ на: комментарий от ss_ash

Таки да, что-то я не заметил. Проблемы у меня были с вайновскими. Нативные идут. Было бы действительно не плохо пофиксить еще wine :)

ngsupb ()
Ответ на: комментарий от megabaks

У меня OpenArena на nouveau летает. И Star Wars JA: Knights of the Force тоже. Надо будет еще потестить RA3 и «Ил-2 штурмовик».

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

А у меня на nouveau minecraft тормозит на дальности видимости выше, чем tiny.

А на блобе нет, зато медленнее работает kwin(хотя тут это почти незаметно).

anonymousss ★★ ()
Ответ на: комментарий от Quasar

>4.2 2D-ускорение там сделано через жопу.

Когда под линуксом тормозило 2D в дискретных nvidia, радеон просто не работал. А вот ТСу чтобы не быть голословным, стоило показать какой-нибудь бенчмарк до и после перехода на нуво. Так это больше похоже на самовнушение, что мол есть повод кроме KMS кушать этот кактус.

Gary ★★★★★ ()
Ответ на: комментарий от Gary

Я, к сожалению, не могу показать бенчмарки, потому что раньше блоб работал, потом с обновлением пришла какая-то шляпа, на которую обновился не глядя; и которая устроила тормоза, похожие на баг 12309, только для графического интерфейса. В экспериментале не хватало несколько пакетов, чтобы поставить блоб оттуда, также желания ставить run пакет, каким бы хорошим унинсталлером он не обладал, нет. В итоге я поставил nouveau, который, оказывается, худо-бедно, но 3d крутит и графику не вешает. Недельку-две на нуво перебьюсь, а там, может, исправят.
И вопрос был про вайновские игры, потому что нативные, например, OpenArena, идут.
P.S. Насколько помню, glxgears, хоть он и не тест, с блобом выдавал промерно 12000, а с нуво 4000

ss_ash ★★ ()

Такое бывает, если не поставить 32-битную версию всех нужных библиотек. Особенно смотри на nouveau-dri (для арча пакеты называются lib32-nouveau-dri и nouveau-dri).

ChALkeR ★★★★★ ()

не знаю как в debian пакет называется, а в fedora 17 нужно установить пакет mesa-dri-drivers.i686 wine сама не тянет эту зависимость т.к. она специфична. а для системы (glxinfo, glxgears) достаточно x86-64 пакета.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.