LINUX.ORG.RU

WoW пропадает звук


0

1

После запуска все нормально, но стоит любому другому приложнию обратится к звуковой подсистеме (например проиграть уведомление о сообщении), звук в игре отваливается намертво. Если после этого зайти в настройки звука (в игре) и поменять что-либо - то после применения новых настроек звук появляется.

Гуглил, гуглил - ненагуглил.

И да, галочку sound in background ставил, не помогает.

Ответ на: комментарий от sl4mmer

> Ну это костыль, а не решение.

Поставь пакет wine-pulse.

bsdfun ★★★★★ ()

Да, есть такая проблема. Проявляется не в 100% случаев когда другое приложение обращается к звуковой подсистеме, т.е. пиджин может крякнуть в фоне - и все останется нормально. Но может и так, что звук в варкрафте исчезнет. Происходит это, судя по мануалам, потому что wow НЕ умеет выводить звук через pulse и пользуется напрямую ALSA.

Frakhtan-teh ★★ ()
Ответ на: комментарий от Frakhtan-teh

Пульс не нужен. Да, и вов ничего не знает про пульс и альсу, про них может знать только wine.

Xellos ★★★★★ ()
Ответ на: комментарий от Frakhtan-teh

> wow НЕ умеет выводить звук через pulse и пользуется напрямую ALSA.

wine, а не wow. И давно умеет пульс.

tensai_cirno ★★★★★ ()
Ответ на: комментарий от tensai_cirno

> Летаю в eve, пульс, fedora 15, умвр

Наверное он в федоре какой то особенный, ибо в бубунте постоянно глючит и адски грузит процессор.

bsdfun ★★★★★ ()
Ответ на: комментарий от bsdfun

Он и в убунте у меня прекрасно работал. И в дженту, и даже в арче.

tensai_cirno ★★★★★ ()

Та же фигня. Единственное, что помогло, так это отключение всех остальных звуков и уведомлений.

Pymba ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.