LINUX.ORG.RU

немогу mmap /dev/dsp


0

0

Под RedHat 9.0 (kernel 2.4.20-8) поставил alsa-1.0.0-rc2. Зарустил alsaconf. Оно мне нашло мою звуковую: snd-intel8x0 (у меня AC`97 на SiS702). В modules.conf прописано всё как надо: сами дрова, эмуляция под oss. Но есть проблема: при запуске quake3 пишет, мол, /dev/dsp защищён от записи. Команда chmod o+rw /dev/dsp ничего неисправила. Задал для /dev/dsp: -rw-rw-rw-. Всё тоже.

С oss драйвером было так (i810_audio): quake3 запускался со звуком. Вроде всё нормуль. Но при загрузке уровня после awayting snapshot игра висла вместе с иксами насмерть. Отключение же звука: quake3 +set s_initsound 0 давало нормальный результат. Но без звука играть не прикольно. Даже если после запуска в консоли игры прописать: /set s_initsound 1 и /snd_restart, всеравно после перезапуска уровня всё висло. Вот! Помагите!

Re: немогу mmap /dev/dsp

echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss Может поможет

anonymous ()
Ответ на: Re: немогу mmap /dev/dsp от anonymous

Re: Re: немогу mmap /dev/dsp

млин:) echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss Может поможет

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.