LINUX.ORG.RU
ФорумGames

:: unable to satisfy dependency 'libstdc++6' required by darkest-dungeon

 ,


0

1

Добрый день. Вопрос знатокам Арча. Пытаюсь установить игрушку darkest-dungeon по этой инструкции -

dotslashplay

Скачал все файлы с [GOG] (https://www.gog.com/game/darkest_dungeon)

Собрал пакеты к основной игре ( без дополнений)

$ sh ./play-darkest-dungeon.sh

Using darkest_dungeon_24839_28859.sh Checking integrity of darkest_dungeon_24839_28859.sh OK

Extracting data from darkest_dungeon_24839_28859.sh OK

*Building darkest-dungeon-data_24839-gog28859+20190520.5_any.pkg.tar OK *

Building lib32-darkest-dungeon_24839-gog28859+20190520.5_x86_64.pkg.tar OK

Building darkest-dungeon_24839-gog28859+20190520.5_x86_64.pkg.tar OK

Install «Darkest Dungeon» by running the following commands as root: 32-bit version: *pacman -U «/home/rdga1/Загрузки/Darkest Dungeon - GOG Linux/darkest-dungeon-data_24839-gog28859+20190520.5_any.pkg.tar» «/home/rdga1/Загрузки/Darkest Dungeon - GOG Linux/lib32-darkest-dungeon_24839-gog28859+20190520.5_x86_64.pkg.tar» *

64-bit version: *pacman -U «/home/rdga1/Загрузки/Darkest Dungeon - GOG Linux/darkest-dungeon-data_24839-gog28859+20190520.5_any.pkg.tar» «/home/rdga1/Загрузки/Darkest Dungeon - GOG Linux/darkest-dungeon_24839-gog28859+20190520.5_x86_64.pkg.tar» *

Делаю все строго по инструкции

sudo pacman -U «/home/rdga1/Загрузки/Darkest Dungeon - GOG Linux/darkest-dungeon-data_24839-gog28859+20190520.5_any.pkg.tar» «/home/rdga1/Загрузки/Darkest Dungeon - GOG Linux/lib32-darkest-dungeon_24839-gog28859+20190520.5_x86_64.pkg.tar»

Получаю такую ошибку -

загрузка пакетов…

разрешение зависимостей…

предупреждение: не удалось разрешить «libstdc++6», зависимость «darkest-dungeon»

:: Этот пакет не может быть обновлен из-за неразрешимых зависимостей:

  *darkest-dungeon*

:: Вы уверены что хотите пропустить этот пакет при обновлении? [y/N]

ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)

:: unable to satisfy dependency ‘libstdc++6’ required by darkest-dungeon

Вопрос. Куда из Арча дели это чудо библиотеку ‘libstdc++6’?

Спсб за внимание!

Ответ на: комментарий от DllMain

/sbin/ldconfig -p | grep libstdc

libstdc++.so.6 (libc6,x86-64) => /usr/lib/libstdc++.so.6

libstdc++.so.6 (libc6) => /usr/lib32/libstdc++.so.6

libstdc++.so (libc6,x86-64) => /usr/lib/libstdc++.so

libstdc++.so (libc6) => /usr/lib32/libstdc++.so

ЧЕго ему Не хватает?

rdga12 ()

Вопрос. Куда из Арча дели это чудо библиотеку ‘libstdc++6’?

пакета с именем libstdc++6 не существует и вроде вообще никогда не было в Arch.

неверно прописанные зависимости пакета. pacman -Ud поможет тебе.

dhampire ★★★ ()
Ответ на: комментарий от anonymous

Ему не хватает дебиана/убунту

Это где so-шки без версии в dev пакетах лежат?

$ apt-file search libboost_filesystem.so
libboost-filesystem1.67-dev: /usr/lib/x86_64-linux-gnu/libboost_filesystem.so
libboost-filesystem1.67.0: /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.67.0
Лол

DllMain ()