LINUX.ORG.RU

[неосиливаю] Кросс-компиляция


0

1

Привет, ЛОР!

Собственно, мне нужно было собрать intltool под MinGW из сорцов, но возникла проблема со старой версией PERL (у меня стоит в MinGW 5.6, а нужна минимум 5.8). Как корректно обновить PERL из сорцов? Манов в гугле не особо нашел.

Как корректно обновить PERL из сорцов? Манов в гугле не особо нашел.

Ты даже не представляешь, просто взять и пересобрать из исходников новую версию.

babusha ()
Ответ на: комментарий от babusha

Ты не представляешь, пробовал уже.

С dmake пробовал, он мне пожаловался, что ему неизвестна команда cd.

LongLiveUbuntu ★★★★★ ()

Есть у меня акк на last.fm, а вот денег нет за него платить... В то же время Ритмбокс прекрасно играет last.fm нахаляву, вот я и решил скомпилять Ритмбокс под винды из сорцов и слушать радио... Ну и вообще мне он нравится куда больше чем iTunes. Так то...

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

Мне кажется лучше тогда использовать cygwin, хотя придется такскать либы cygwin если будет нужно перенести.

babusha ()

просто поищите пакеты mingw32*
во всех нормальных дистрах оно есть.

anonymous2 ★★★★★ ()

MinGW прекрасно обновляется по частям. Тебе нужен перл? Скачиваешь на соурс форж мингвешном (сайт лежит уже черти сколько) последний тарболл с перлом и распаковывешь в каталог с мингв. А если мингв достаточно юный, можешь воспользоваться их встроенным обновлятором mingw-get.

Vamp ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.