LINUX.ORG.RU

Sintegrial Text Editor


0

0

Sintegrial Technologies выпустила бета-версию бесплатного (под GPL лицензией) мультиплатформенного редактора текстов - S.T.E. (версия 0.1.1)

Сайт проекта: http://ste.sintegrial.com

Редактор основан на фреймворках Qt и Qscintilla и может работать в ОС Linux, Unix, Windows, и прочих.

Основные возможности программы:

- мультитабовый интерфейс;

- подсветка синтаксиса для более 30 языков и форматов;

- более 70 кодировок (через интерфейс iconv);

- преобразование концов строк win-unix-mac;

- автодополнение введенного текста;

- сворачивание участков текста;

- навигация с помощью закладок;

- быстрый поиск выбранного текста;

- поиск с регулярными выражениями;

- и другие возможности.

что-то мне подсказывает что это очередной первая-прога-на-куте-текстовой-редактор от очередного второкурсника. Из разряда, «О, QScintilla2!!! Почти готовый редактор! Дайка я кнопочек на все слоты ей понавешую!» Знакомо.

Averrin ()

какие профиты при использовании сабжа KDEшником-линуксоидом по сравнению с kate? (подчёркнутым жирным я кагбэ намекаю, что не хочу слышать о кроссплатформенности и libkde*-независимости; т.е. спрашиваю для себя, а не вообще.)

arsi ★★★★★ ()
Ответ на: Trolling от ii-system

> Уважаемый, пожалуйста, занимайтесь троллингом в другом месте...

он полностью прав

lester ★★★★ ()
Ответ на: комментарий от Camel_Toe

> - автодополнение введенного текста;

показать скриншот, или на слово поверите, что в kate это есть? ;)

arsi ★★★★★ ()
Ответ на: комментарий от arsi

поскольку вопрос стоит в плоскости примерно «чем BMW лучше Mercedes», лучшим ответом, наверное, будет - «решать Вам». Дело даже не в профитах, т.к. программа имеет версию 0.1.1, что говорит о самой начальной стадии развития. Тем более любая рекомендация со стороны лиц, причастных к разработке в той или иной мере, уже является рекламой и навязыванием чужого мнения :) Линуксоиды и КДЕ-шники такие же люди со своим личным мнением об удобстве и эстетике даже в пределах одной ОС. Кому-то нравится kate, кто-то сидит в nano, кто-то в emacs.

по поводу слотов и кнопочек, если это действительно не троллинг (в чем есть большие сомнения по понятной причине), можно сказать так: Scintilla - отличный компонент для создания текстового редактора, но конечному пользователю придется работать именно со слотами и кнопками. И эффективность использования scintilla будет прямо пропорциональна эффективности и возможностям кнопочной оболочки. STE - всего лишь один из вариантов оной. Кроме scintilla, существует iconv, отличная библиотека для работы с различными кодировками, и Qt, отличная библиотека для увязывания всего в одно целое. Вы же не будете приобретать одни колеса, если вам нужен автомобиль.

ii-system ()

Вот сколько редакторов перебрал, а ничего лучше Vim'а нет и не предвидится :(

GotF ★★★★★ ()

На сайте информации минимум - оно разметку и синтаксис JavaFX подсвечивать умеет?

Amp ★★★ ()
Ответ на: комментарий от ii-system

> поскольку вопрос стоит в плоскости примерно «чем BMW лучше Mercedes»

вопрос стоит в плоскости «стоит ли мне менять мой привычный XXX на ваш неведомый мне YYY?», не более и не менее.

под слакварь нет пакетов ни сабжа, ни Scintilla, т.е. писать слакбилды придётся самому. это не проблема, но это время и, возможно, немалое, но которое я согласен потратить на сборку более удобной(?) среды.

поэтому повторю вопрос ещё раз и медленно (могу три раза, если нужно): какие преимущества сабжа перед kate? не emacs, не vi(m), не vi$ual $tudio, не borland c++ builder, а именно kate, который не отдельная os и не мега-ide, а именно многофункциональный текстовый редактор с подсветкой синтаксиса «и чуть больше», в точности как сабж. ня?

arsi ★★★★★ ()
Ответ на: комментарий от GotF

Вот сколько редакторов перебрал, а ничего лучше Vim'а нет и не предвидится :(

emacs! -)

TirNaNOg ()

А почему там по ссылке на скриншоте - SciTE?

yoghurt ★★★★★ ()

Автодополнение - кривое, вставкой парных символов невозможно пользоваться, биндинги - вантузные, поэтому невменяемые, настройке не подлежат. Неюзабельная недоделка.

TirNaNOg ()

% sudo dpkg -i ste-0.1.1-amd64.deb
Selecting previously deselected package s.t.e..
(Reading database ... 381523 files and directories currently installed.)
Unpacking s.t.e. (from ste-0.1.1-amd64.deb) ...
dpkg: dependency problems prevent configuration of s.t.e.:
s.t.e. depends on libqt4-dev (>= 4.6.0); however:
Version of libqt4-dev on system is 4.5.3really4.5.2-0ubuntu1.
s.t.e. depends on libqscintilla2-dev (>= 2.4); however:
Package libqscintilla2-dev is not installed.
dpkg: error processing s.t.e. (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

Зачем бинарному пакету девелоперские зависимости? O_o

anotheranonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.