LINUX.ORG.RU

invalid pseudo-version fatal: git fetch-pack: expected shallow list

 


0

1

Пытаюсь собирать https://github.com/wal-g/wal-g Но выдается ошибка.

cat /etc/redhat-release

CentOS Linux release 7.6.1810 (Core)

mkdir /root/go
export GOPATH=/root/go
go get github.com/wal-g/wal-g
package github.com/wal-g/wal-g: no Go files in /root/go/src/github.com/wal-g/wal-g

cd $GOPATH/src/github.com/wal-g/wal-g
make install
go get -u golang.org/x/lint/golint
go: github.com/golang/mock@v1.3.1-0.20190508161146-9fa652df1129: invalid pseudo-version: git fetch --unshallow -f origin in /root/go/pkg/mod/cache/vcs/e0a6dff9fb6c1f7c23e670e933cb00d791bc91d7acab4aef9d400ff3e9838f0b: exit status 128:
	fatal: git fetch-pack: expected shallow list
make: *** [install] Error 1

yum list golang
Installed Packages
golang.x86_64  1.13.3-1.el7 @epel

Как исправить?

Читаю README, в слух, громко, дорого.

https://github.com/wal-g/wal-g#installation

Но вообще, конечно, со структурой проекта там всё очень-очень плохо и не канонично.

go get -v github.com/wal-g/wal-g/main/pg
go build -o ~/bin/wal-g github.com/wal-g/wal-g/main/pg

Может быть даст искомый результат.

beastie ★★★★★ ()
Ответ на: комментарий от beastie

Оказалось что нужно обновить git.

Спасибо за помощь.

chemtech ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.