LINUX.ORG.RU

netbeans + jdk 8

 , ,


0

1

Уже установлен jdk8

java -version
java version "1.8.0_74"
Java(TM) SE Runtime Environment (build 1.8.0_74-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.74-b02, mixed mode)
при
emerge -vp netbeans
предлагает поставить jdk7
сам netbeans - dev-util/netbeans-8.0.2:8.0::gentoo
Почему такая фигня, вроде netbeans-8.0.2 работает на jdk8, почему требует старую джаву?
и как ему показать jdk8?


весь джава треш (netbeans, eclipse, idea) кроме JDK/JRE всегда было гораздо проще и быстрее ставить и обновить просто скачав бинарники с сайтов.

kep ()
Ответ на: комментарий от Black_Shadow

правильно я понимаю, что netbeans с portage запилен только с поддержкой jdk:1.7?
И выхода два, либо откатывать джаву, либо тянуть бинарник с офсайта?

zv_X ()
Ответ на: комментарий от zv_X

netbeans с portage сам бегает на 7й жаве. поддержка jdk8 сделана внутри IDE: Tools - Java Platforms - Add Platform

vostrik ★★★☆ ()
Ответ на: комментарий от Black_Shadow

Можно поправить ебилд (если, конечно, сам netbeans при этом будет работать).

Оговорка, «если будет работать», смущает.
Кто-то на gentoo собрал netbeans + jdk8?

zv_X ()
Ответ на: комментарий от zv_X

Да заведётся скорее всего, просто мейнтейнеров мало, они ленивые, вот пакеты и не обновляют.

Если запустишь, заведи заодно тикет на bugs.gentoo.org о том, что netbeans тянет jdk-7, несмотря на то, что отлично работает с 8.

Вообще все java старше 8 давно пора выпиливать из дерева насовсем, там 9 на подходе.

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

подредактировал ебилды - получил маскировку


 emerge -vp netbeans

These are the packages that would be merged, in order:

Calculating dependencies \ * Digest verification failed:
 * /usr/portage/dev-util/netbeans/netbeans-8.1.ebuild
 * Reason: Failed on SHA256 verification
 * Got: 48c980f708e8198db21211d5d91c782330da4541b9c151d969d5a4f11e09d42b
 * Expected: 22a19f05bdcea85475c0451df867367b69363bfbc6280f78b087248d9f8e9513
 * Digest verification failed:
 * /usr/portage/dev-util/netbeans/netbeans-8.0.2.ebuild
 * Reason: Failed on SHA256 verification
 * Got: 9d9985b1a4308a65156622f561bafa82b82591c6f4c46016b356ba16d83f77e8
 * Expected: d92c4fe6abc1b49bd92d0d64569c862894452dbe15a705b6fa341ec293bcd918
... done!

!!! All ebuilds that could satisfy "netbeans" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/netbeans-8.1::gentoo (masked by: corruption)
- dev-util/netbeans-8.0.2::gentoo (masked by: corruption)

Чего собственно и следовало ожидать :(

zv_X ()
Ответ на: комментарий от BattleCoder

Ну что, нет никаких мыслей по поводу еблилда? Чего может не хватать?

zv_X ()
Ответ на: комментарий от zv_X

Точно сделано? Ну а что тут думать - сообщение об ошибке же пишет, что контрольная сумма не совпадает - естественно, так как файл изменён.

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

Да уж, больше сотни пакетов надо просмотреть...
Буду копать потихоньку.
Где-то видимо зарыто еще жестко jdk:1.7

zv_X ()
Ответ на: комментарий от BattleCoder

Попытка :)
Замаскировал netbeans-8.0.2 собрал с тестовой 8.1 с ней тянутся нормальные зависимости, и в ебилде уже

DEPEND=">=virtual/jdk-1.7
	dev-java/javahelp:0"
RDEPEND=">=virtual/jdk-1.7
но все же из-за пакета dev-java/guava-18.0:18 по его ебилду требуется jdk:1.7
внес правки в ебилд правда в ебилде ссылка на обсуждения бага с jdk, (с мыслью «возможно не заведется»).
Так же поправил немного ебилд самого netbeans
-Dpermit.jdk8.builds=true -f l10n/build.xml build || die
Ну и все что рекомендует emerge keyword changes и USE changes само собой.
Попробовал собрать.
Но так и есть, библиотека guava не собралась.
На гитхабе на оф ветке библиотеки ясно сказано.

We unit-test and benchmark the libraries using only OpenJDK 1.7 on Linux. Some features, especially in com.google.common.io, may not work correctly in other environments.

Пробовать собирать без этой библиотеки, кажется тоже не айс...
Так понимаю надо угомониться и собирать с jdk7, но я собрал eclipse (причем без 130 пакетов зависимостей как с netbeans), пока так, а там видно будет.
Такая вот ерунда. У кого есть идеи, буду рад. Уже чисто спортивный интерес теперь :)

zv_X ()
Ответ на: комментарий от zv_X

Eclipse emerge поставил древнющий:

Version: Juno Service Release 1
Build id: 20120920-0800
(c) Copyright Eclipse contributors and others 2000, 2012.  All rights reserved.
Поэтому поставил все же netbeans-8.1, c доустановкой jdk-7 тоже, возможно нужна она только для guava.
Ну и хай с ней.
Главное нетбинс работает на правильной джаве.
Product Version: NetBeans IDE 8.1 (Build 20160322-unknown-revn)
Updates: Updates available to version NetBeans 8.1 Patch 1
Java: 1.8.0_74; Java HotSpot(TM) 64-Bit Server VM 25.74-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_74-b02
System: Linux version 4.1.15-gentoo-r1 running on amd64; UTF-8; en_US (nb)
Кажется теперь исчерпывающе.

zv_X ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.