LINUX.ORG.RU

Установка Qt Assistant, Linguist, etc

 , ,


0

1

Доброго здоровьица!

Вопрос: вот я поставил Qt на Ubuntu. Скачал с сайта инсталлер, и поставил сам qt 5.5 и qt creator в /opt/Qt.

Но как мне правильно установить Assistant, Linguist, Designer? Да, из creator есть доступ к этому. Но как мне отдельно правильно поставить? Никак не нахожу в инсталляторе этого.

Очевидно, что он идёт в той же поставке. Инсталлер должен был создать *.desktop файлы для них.

yurikoles ★★★ ()
Последнее исправление: yurikoles (всего исправлений: 1)
Ответ на: комментарий от yurikoles

ну смотрите. В Qt Creatore эти менюхи есть в боковом меню. А как мне запустить как отдельное приложение?

zamazan4ik ★★ ()
Ответ на: комментарий от yurikoles

не знаю, что он там должен был создать. Но ничего нет. Дистриб - kubuntu 14.04

zamazan4ik ★★ ()

Чем Qt из из реп не устроил? Там лингвист вроде в qttools5-dev-tools

wolph ★★ ()
Ответ на: комментарий от wolph

есть репы разработчика? а то мне что-то кажется, что в офф. репах будет немного более старое. На всякий случай, подскажите пожалуйста, какой командой ставится весь qt5 и qt creator со всякими fcbcntyfnvb b ghjxtt

zamazan4ik ★★ ()
Ответ на: комментарий от zamazan4ik

Вроде qt5-default надо поставить. А что недостаточно последний - а оно надо тебе, всякие Qt3D и Canvas3D, или чего там накрутили?

wolph ★★ ()
Ответ на: комментарий от wolph

тогда можно вопрос? почему инсталлятор с сайта не ставит всё это? Или я просто не умею запускать?

zamazan4ik ★★ ()
Ответ на: комментарий от zamazan4ik

А разве не ставит? Разве прямо из креатора нельзя запустить все эти посторонние утилиты?

wolph ★★ ()
Ответ на: комментарий от wolph

а как запустить отдельно? Дизайнер знаю как, ассистент тоже, лингвиста не знаю, не пробовал. Но разве нельзя запустить отдельной прогой всё это? Раньше точно можно было

zamazan4ik ★★ ()
Ответ на: комментарий от zamazan4ik

Но разве нельзя запустить отдельной прогой всё это?

/usr/bin/assistant
/usr/bin/desugner

И в таком же духе

wolph ★★ ()
Ответ на: комментарий от wolph

Чем Qt из из реп не устроил? Там лингвист вроде в qttools5-dev-tools

Отличный совет, как наступить на грабли. Qt 5 в deb-дистрах пакуют какие-то наркоманы. Он, во-первых, там очень старый и сырой (привет блёклым шрифтам с 5.0.0 до 5.4.1), а во-вторых, с ним постоянно какие-то проблемы.

Лучше всего ставить именно инсталлером с официального сайта в /opt. Там и возможность обновления имеется сразу после выхода новой версии. В отличие от говнореп.

Так что проще всего взять и ручками написать нужные .desktop-файлы.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

Qt 5 в deb-дистрах пакуют какие-то наркоманы.

Судя по недавней теме, где писали что в Федоре QtCreator тянет Viber, в rpm ситуация не намного лучше)

По теме:
Отдельные приложения должны лежать где-то тут: /opt/Qt/5.5/gcc/bin

CrossFire ★★★★★ ()
Последнее исправление: CrossFire (всего исправлений: 2)
Ответ на: комментарий от EXL

Это ты у нас старый и сырой.
QtCreator 3.4.1 с Qt 5.4.2 в Debian Testing ставится пакетом qt-sdk вместе со всеми дизайнерами, лингвистами и прочими ассистентами. И никаких проблем.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.