LINUX.ORG.RU

И снова Compose Key


0

1

проапдейтил на свою голову Ф18 до Ф19, естественно новый Сinnamon (2.0.3).

Всю жизни у меня на правый Alt повешено Compose key и AltGr. Теперь что то отвалилось и не знаю где чинить. Вещи типа ½ и ¾ работают, но вот правильные елочки для цитирования (и куча других полезных штук) больше поставить не могу. В dconf-editor не нашел. Кто сталкивался? Где грабли?

Какой input method используется?

но вот правильные елочки для цитирования (и куча других полезных штук) больше поставить не могу

Это был собственный ~/.XCompose или стандартный?

proud_anon ★★★★★ ()
Последнее исправление: proud_anon (всего исправлений: 1)
Ответ на: комментарий от proud_anon

Это был собственный ~/.XCompose или стандартный?

стандартный. Я даже .XCompose в хомяке не создавал никогда.

firsttimeuser ★★★★★ ()
Ответ на: комментарий от proud_anon

Какой input method используется?

English (US). Добавил Ukrainian (согласно раскладке) через ibus-setup, переключился — те же яйца…

firsttimeuser ★★★★★ ()
Ответ на: комментарий от firsttimeuser

English (US).

Вопрос был про IM.

ibus

Ну вот поэтому XCompose и не работает. Могу предположить, что тебе поможет ibus-table-compose.

Gotf ★★★ ()
Ответ на: комментарий от firsttimeuser

стандартный. Я даже .XCompose в хомяке не создавал никогда.

Хм... И Compose + < + < не работает?
В принципе, это очень странное явление, что некоторые сочетания работают, а некоторые — нет. В IBus, ЕМНИП, полностью захардкожены сочетания Compose.
Можно для начала диагностики попробовать переключить Compose на какую-нибудь другую клавишу или отключить AltGr — в общем, сделать так, чтобы Compose ни с чем не пересекался.

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon

чтобы Compose ни с чем не пересекался

Прошу прощения, что влезаю. А об’ясните, пожалуйста, как это сделано, что он «пересекается» и какие это выгоды дает?

Zmicier ★★★★★ ()
Ответ на: комментарий от proud_anon

Можно для начала диагностики попробовать переключить Compose на какую-нибудь другую клавишу или отключить AltGr — в общем, сделать так, чтобы Compose ни с чем не пересекался.

попробовал с помощью setxkbmap -option 'compose:rctrl' и setxkbmap -option 'compose:caps'

могу ставить ½ ⅔ ⅘ © и прóчее… но в кириличной раскладке не работает ничего. Пробовал удалять украинскую и добавлять русскую раскладку — те же яйца. Интересно что при смене раскладки Compose слетает с правого Colntrol или с CapsLock, приходится снова исполнять setxkbmap…

Как диагностировать?

firsttimeuser ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.