LINUX.ORG.RU

Непонятки с пакетами в федоре

 ,


0

1
[morse@laptop ~]$ sudo yum install shim
Загружены модули: langpacks, refresh-packagekit
Пакет shim-0.4-1.fc19.x86_64 уже установлен. Проверка обновлений.
Выполнять нечего
[morse@laptop ~]$ sudo yum reinstall shim
Загружены модули: langpacks, refresh-packagekit
Установленный пакет shim-0.5-1.fc20.x86_64 (из updates-testing) недоступен.
Ошибка: Выполнять нечего

Это как вообще? Ты уж определись, какой пакет стоит?

У меня загрузка внезапно поломалась: файл /EFI/BOOT/BOOTX64.EFI больше не работает.

Система - федора 20

★★★★★

Ответ на: комментарий от awesomenickname
[morse@laptop ~]$ yum repolist enabled
Загружены модули: langpacks, refresh-packagekit
Идентификатор репозитория                 репозиторий                                       состояние
fedora/20/x86_64                          Fedora 20 - x86_64                                37 919
fedora-steam/20/x86_64                    Steam for Fedora                                       1
google-earth                              google-earth                                           1
rpm-sphere                                RPM Sphere                                         7 213
rpmfusion-free-rawhide/x86_64             RPM Fusion for Fedora Rawhide - Free                 417
rpmfusion-nonfree-rawhide/x86_64          RPM Fusion for Fedora Rawhide - Nonfree              190
updates/20/x86_64                         Fedora 20 - x86_64 - Updates                           0
updates-testing/20/x86_64                 Fedora 20 - x86_64 - Test Updates                 12 623
morse ★★★★★ ()
Ответ на: комментарий от alpha

В смысле совсем убрали? Больше такого пакета в федоре 20 нет? А кто теперь предоставляет файл /EFI/BOOT/BOOTX64.EFI ?

morse ★★★★★ ()
Ответ на: комментарий от morse

Это тестинг, положили, потестили, не понравилось, убрали. Старая версия доступна, yum тебе её показал.

alpha ★★★★★ ()
Ответ на: комментарий от morse

yum показывает версии доступные в текущих репозиториях (если ты ничего там с --releasever не менял конечно)

И бывает что в них лежат пакеты от более старых версий. Если всё совместимо, то полная пересборка не нужна.

Вообще, раз сидишь на f20, пользуйся koji и bodhi. В первой - все когда-либо сделанные сборки пакета. Во второй - можно отследить как эти сборки проходят процесс тестирования и попадают ли в финальные репозитории.

alpha ★★★★★ ()
Ответ на: комментарий от alpha

а я вот сейчас воркстанцию от rhel мучаю.Завтра буду думать, как ядро 3.17.2 присобачить.

erzent ☆☆ ()
Ответ на: комментарий от alpha

The ELRepo Project есть вариант присобачить, не нравится мне на старой btrfs сидеть, хочу свежую, а то 2 диска в ноуте, а 0 рейд на древней версии глючный.

erzent ☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.