LINUX.ORG.RU

Gnome 3.6 + 1C:Предприятие = не печатаются русские буквы!

 ,


0

1

Доброго времени суток. Столкнулся с такой пробемой: 1С:Предприятие 8.3 (linux версия) - не воспринимает русские буквы. Причина скорее всего Gnome (точнее то что сейчас заведует за переключение клавиатуры), потому что если поставить переключение средствами xorg то все в порядке, все печатает, но нет индикатора, да и периодически слетают настройки.

Собственно у меня 2 вопроса : 1) Можно ли как то подпилить то что отвечает за раскладку в Gnome 3.6 чтобы начало печатать русские буквы? 2) Можно ли как то прикрутить индикатор, раскладку для каждого окна средствами Xorg? (если можно то как)?

ОС: Fedora 18. Gnome: 3.6.3.1 Ядро: 3.8.4-202 Xы: 1.13.3

Заранее всем спасибо!

потому что если поставить переключение средствами xorg то все в порядке, все печатает, но нет индикатора

я бы лучше поборол вот это проблему, ибо всю жизнь настраивал раскладку DE-независимым способом...

Pinkbyte ★★★★★ ()

1) Можно ли как то подпилить то что отвечает за раскладку в Gnome 3.6 чтобы начало печатать русские буквы?

Это в гноме же настраивается.

Extraterrestrial ★★★★★ ()
Ответ на: комментарий от AlexCones

Техническая поддержка говрит - Fedora 18 не поддерживается!

Они четко ответили что поддерживаемые дистрибути Ubuntu 12.04, Fedora 17, Mint 12, следовательно помогать не будут..

vsafonin ()
Ответ на: комментарий от Extraterrestrial

А где?

Русская раскладка есть, и во всех приложениях она работает, не работает только в 1С-ке. Если я ошибаюсь, поправте, и куда чего настраивать

vsafonin ()
Ответ на: комментарий от Pinkbyte

Например?

Ни как не получается побороть, то что раскладки игнорируются, или перебиваются, приходится заного прописывать: setxkbmap -layout 'us,ru' -option 'grp:alt_shift_toggle, grp_led:caps'

Что не очень то удобно.

С индикатором то еще более менее понятно (xxkb, fbxkb)

vsafonin ()
Ответ на: комментарий от bvn13

Тормозит безбожно!

Тормозит, подвешивает систему, и да клава тоже слетает..может я не понял как его готовить...

vsafonin ()
Ответ на: И да проблему не решает. от vsafonin

А нет решает)

Дело в том что в настройках стоял что метод ввода такой же как и у Gnome повесил на X. Жить можно)

Спасибо.

vsafonin ()

Ненужно + Ненужно=)

man setxkbmap
man startx

Ставь openbox и tint2


Грузи startx Xorg


~/.xinitrc:


setxkbmap -layout «us,ru» -option «grp:caps_toggle,grp_led:scroll»
tint2 &
uxterm -bg black -fg white &
exec openbox-session



А дальше запускай свой 1C через терминал

ubuntuawp ★★ ()
Ответ на: комментарий от ubuntuawp

Пытался пересесть на легкие ДЕ

Пытался одно время пользоватся и Openbox и Fluxbox, тайловые ДЕ xmonad, awesome. По опыту ничего мне это не дало, почему то когда начанаю обживать «эти легкие ДЕ», ставлю кучу костылей - в итоге еще хуже чем в Gnome.

В данном случае решил координально, но эффективно - установка debian stable + kde, доволен как удав))

vsafonin ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.