LINUX.ORG.RU

lampp не запускается

 , ,


0

1

Подскажите пожалуйста, как решить неполадку:

XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.

Библиотеку ia32-libs уже установил - не помогает. Система - Ubuntu 12.10

Ответ на: комментарий от AITap

Спасибо большое за ответ! Дело в том, что я не могу удалить lampp, т.к. там базы данных и код. Я уже давно таскаю ламп из линукса в линукс и раньше было все нормально, а сейчас вылезла такая штука :(

gwyllum ()
Ответ на: комментарий от gwyllum
dpkg --add-architecture i386
apt-get update
apt-get install lib<что угодно>:i386

Начните с libc6:i386. Имена библиотек посмотрите в выводе ldd и в скрипте, который жалуется на отсутствие библиотек.

Подумайте, не лучше ли будет перенести базы и код в системные места их хранения.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Я пробовал команду

root@welcometohell:/home/eugenes# ldd -v /opt/lampp/lampp
	не является динамическим исполняемым файлом

Установил все библиотеки libc6, кроме dbg & dev. Все равно не помогает, можно что-то еще сделать?

gwyllum ()
Ответ на: комментарий от gwyllum

ldd -v /opt/lampp/lampp
не является динамическим исполняемым файлом

Верно, это скрипт. Ищите динамические ELF-бинарники (например, /opt/lampp/.../apache2), которые он вызывает. Посмотрите, как скрипт, который печатает сообщение о необходимости установленных 32-битных библиотек, определяет их отсутствие (см. grep -Fr 'XAMPP is currently only availably as 32 bit application' /opt/lampp).

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Спасибо за ответ! Вот что я нашел в /opt/lampp/lampp:

# XAMPP is currently 32 bit only
case `uname -m` in
	*_64)
	if /opt/lampp/bin/php -v > /dev/null 2>&1
	then
		:
	else
		$de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
		$de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
		exit

Не подскажете, что мне нужно установить?

gwyllum ()
Ответ на: комментарий от gwyllum

if /opt/lampp/bin/php -v > /dev/null 2>&1

32-битные библиотеки, которые потребует /opt/lampp/bin/php.

AITap ★★★★★ ()
9 июня 2013 г.
Ответ на: комментарий от gwyllum

Поставь Skype и все 32-ух битки подтянуться автоматически и XAMPP заработает.

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype && sudo apt-get -f install
anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.