LINUX.ORG.RU

арч по два раза впадает в хибернейт


0

2

проблема в том, что после выхода из хибернейта, в течении 5 секунд арч снова в него впадает. Приходится ещё раз его будить, после чего работает нормально.

Засыпание/просыпание срабатывает при открытии/закрытии крышки и нажатии клавиш.

Раньше на этом же ноуте арч просыпался/засыпал без проблем.

Linux my_host 3.6.4-1-ARCH #1 SMP PREEMPT Mon Oct 29 15:13:56 CET 2012 i686 GNU/Linux

xfce4

что можно сделать, чтобы он не засыпал как только проснется?

Видимо таки дважды срабатывает хук на закрытие крышки. Один от systemd, другой ещё от кого-то.

post-factum ★★★★★ ()
Ответ на: комментарий от KivApple

ну так в DE нет пункта «просыпаться при открытии крышки»
там есть только «засыпать»

попробую в logind.conf добавить HibernateKeyIgnoreInhibited=yes

sergey-novikov ★★★ ()
Ответ на: комментарий от sergey-novikov

Я говорю как раз отключить это «засыпать» в DE.

Ну а ключи в файле тебе нужны иные:

[kiv@kiv-notebook ~]$ cat /etc/systemd/logind.conf 
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# See logind.conf(5) for details

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes

HandlePowerKey=ignore

HandleSuspendKey=ignore

HandleHibernateKey=ignore

HandleLidSwitch=ignore

Тогда systemd не будет отправлять в сон ноутбук и это будет делать только само DE.

KivApple ★★★★★ ()
Последнее исправление: KivApple (всего исправлений: 3)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.