LINUX.ORG.RU

Не открывается ни одно приложение

 , ,


0

1

Предыстория такая: поставил Дебиан по минимуму, поднял инет, подключил репы, поставил gdm и IceWM. Затем установил драйвер xserver-xorg-video-radeonhd, прописал в /etc/X11/xorg.conf драйвер radeon, вроде как аппаратное ускорение заработало (у меня ATI Radeon 3470).

Но с иксами какая-то чертовщина. Приложения, которые у меня работают, по пальцам пересчитать: xedit и всякие ненужные часики-гляделки. Из полутора десятка других программ все просто берут и молча не запускаются. Самое забавное, что я даже не знаю, как вернуться в консоль: alt+F{1..7} не даёт никакого эффекта, а если прибить иксы, они чудесным образом воскресают, предлагая мне заново залогиниться. При попытке запуска сессий Xterm или Gnome первое выдаёт ошибку, а второе матерится, что оно у меня не поставлено (что закономерно, я ведь Гном и не ставил).

В общем, нуждаюсь в совете, как мне из этой ерунды сделать нормальные человеческие иксы. И чтобы они, чёрт возьми, не восставали из пепла раньше времени :)

P. S. Всякие текстовые конфиги могу крутить из стоящей по соседству Бубунты.

Затем установил драйвер xserver-xorg-video-radeonhd
прописал в /etc/X11/xorg.conf драйвер radeon

Разве radeonhd при этом используется? Разве все драйвера не были установлены по зависимости от метапакета xserver-xorg?

При попытке запуска сессий Xterm или Gnome первое выдаёт ошибку,

Какую?

И чтобы они, чёрт возьми, не восставали из пепла раньше времени :)

За это отвечает Display Manager. Любой.

~/.xsession-errors смотрели?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Ctrl+Alt+F{1..7}

Точно, спасибо.

Разве radeonhd при этом используется?

Я сначала попытался подключить radeonhd, но он не захотел работать.

~/.xsession-errors смотрели?

http://rghost.ru/41458014

По поводу ошибки Xterm - сейчас гляну.

SkyRider ()
Ответ на: комментарий от SkyRider

Это уже после попыток запустить программы?

AITap ★★★★★ ()

Всем спасибо, проблема решилось банальным «sudo apt-get install xterm». Оказывается, все те приложения, что у меня не запускались - консольные. Соответственно, без xterm'а они и не могли запуститься.

SkyRider ()
Ответ на: комментарий от SkyRider

Ну, или update-alternatives--config x-terminal-emulator и выбрать существующий.

AITap ★★★★★ ()

драйвер xserver-xorg-video-radeonhd

прописал в /etc/X11/xorg.conf драйвер radeon

Тогда нужен xserver-xorg-video-ati, ЕМНИП. Чтоб работало ускорение и прочее. А radeonhd вроде как deprecated же.

ekzotech ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.