LINUX.ORG.RU

jitsi не соединяется с сервером в локальной сети

 ,


0

1

Есть локальная сеть с jabber-сервером в ней. Адрес сервера прописан в /etc/hosts. Сервер по имени пингуется, pidgin и empathy к нему подключаются, а вот jitsi выдаёт ошибку.

Connection failed for the following account: User name: <user@server>. Server name: <server>.

Все настройки по умолчанию. Порт по умолчанию и в jitsi, и в pidgin один, 5222.

При этом с jabber.org jitsi соединяется, и, вроде как, нормально работает.

Пробовал две версии jitsi, стабильную и последнюю сборку. Результат одинаковый.

Сервер — собственноручно настроенный ejabberd. Из настроек там только домен вбит, да пользователи зарегистрированы.

В чём может быть проблема?

★★

Ответ на: комментарий от leave

При попытке подключиться пишет в ~/.sip-communicator/log/jitsi0.log.0 следующее:

SEVERE: impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().700 No server addresses found

fffgh ★★ ()
Ответ на: комментарий от fffgh

Хмм...очень информативно. Может какие шифрование или сжатие на сервере включено с которым jitsi не дружит?

Deleted ()
Ответ на: комментарий от leave

смотри настройки аккаунта

Что посмотреть? Имя сервера там написано. В gui его показывает, по крайней мере.

fffgh ★★ ()
Ответ на: комментарий от leave

Кстати, а оно точно резолвит хостнейм сервера?

Пинг идёт, pidgin подключается. Ещё как-нибудь проверить?

fffgh ★★ ()
Ответ на: комментарий от Deleted

Если вписать user@server_ip

Помимо ошибки, что выше, пишет в лог:

SEVERE: impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectUsingSRVRecords().839 No SRV addresses found for xmpp-client.
SEVERE: impl.gui.main.login.LoginManager.run().462 Failed to register protocol provider. 
java.lang.IllegalStateException: Not connected to server.
	at org.jivesoftware.smack.Connection.addConnectionListener(Connection.java:519)
	at org.jivesoftware.smackx.ServiceDiscoveryManager.init(ServiceDiscoveryManager.java:148)
	at org.jivesoftware.smackx.ServiceDiscoveryManager.<init>(ServiceDiscoveryManager.java:80)
	at org.jivesoftware.smackx.ServiceDiscoveryManager$1.connectionCreated(ServiceDiscoveryManager.java:66)
	at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:596)
	at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:543)
	at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:977)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1159)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:879)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:714)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:437)
	at net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:454)
fffgh ★★ ()
Ответ на: комментарий от Deleted

Может какие шифрование или сжатие на сервере включено с которым jitsi не дружит?

Может быть, если оно включено по умолчанию.

fffgh ★★ ()

Теперь при попытке подключиться обычным образом (с именем сервера) пишет в лог не одну, а целых две строки:

SEVERE: impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectUsingSRVRecords().839 No SRV addresses found for xmpp-client.
SEVERE: impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().700 No server addresses found
fffgh ★★ ()
Ответ на: комментарий от leave

Со скриншотами долго возиться, лучше напишу.

Таб 1, Account.

xmpp username и пароль.

Первое задано верно, второе хоть запоминай, хоть не запоминай, результат один.

Таб 2, Connection.

Enable Gmail notitications for new messages
Enable Google Contacs search
Allow non-secure connections
это всё выключено.

Connect server: имя сервера
Port: 5222

Auto generate resource (включено)
Priority 30

DTMF method: auto (Choose between RTP and Inband)

Таб 3, ICE configuration

Use ICE
Use Google's Jingle/ICE
Use UPnP
Auto discover STUN/TURN servers
Use Jitsi's STUN server in case no other servers are available.

Use Jingle Nodes
Auto discover Jingle Nodes relays
всё включено

Таб 4, Telephony

fffgh ★★ ()
Ответ на: комментарий от Deleted

Он ищет SRV-записи и не находит.

Что это значит? Что делать?

fffgh ★★ ()
Ответ на: комментарий от Deleted

Зачем эти записи, и какие они должны быть — это легко находится. Но куда их вставлять и что для этого ставить — пока непонятно. Не подскажете?

Сервер — это debian 6.

fffgh ★★ ()
Ответ на: комментарий от fffgh

Но куда их вставлять и что для этого ставить — пока непонятно. Не подскажете?

Они прописываются со стороны DNS-сервера. Похоже у тебя есть два варианта: либо поставить полноценный DNS-сервер в локальной сети, либо как-то заставить jitsi не использовать SRV.

Deleted ()
Ответ на: комментарий от Deleted

поставить полноценный DNS-сервер в локальной сети

С ним много возни? Какой выбрать? Клиенты надо будет перенастраивать?

как-то заставить jitsi не использовать SRV.

Не нашёл там подходящей галочки.

fffgh ★★ ()
Ответ на: комментарий от fffgh

С ним много возни?

Нет.

Какой выбрать?

Любой понравившийся.

Клиенты надо будет перенастраивать?

Зависит от организации локальной сети.

Deleted ()
Ответ на: комментарий от Deleted

Зависит от организации локальной сети.

Сервер и пара клиентов, у всех статические айпишники. Пока что домен сервера просто был прописан /etc/hosts у клиентов.

fffgh ★★ ()

use stable version Luke!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.