LINUX.ORG.RU

Знаки препинания в раскладке клавиатуры в ubuntu


0

1

Установила попробовать убунтуё Не получается настроить клавиатуруё Проблема со знаками препинания 9не пишутся при нажатии shift0 Подскажитеб пожалуйстаб как это исправить7

Собственно выше результаты попыток набрать точки запятые скобки и знак вопроса

Да, точки, скобки и запятые каким-то неестественным способом ставятся. Но что делать со знаками вопроса, и как сделать раскладку клавиатуры нормальной7

len4ik ()

Чорт, чаем поперхнулся.

Попробуй вариант раскладки потыкать, в настройках должно быть или sudo dpkg-reconfigure keyboard-configuration.

Kalashnikov ★★★ ()

Это убунтам бро, там вечные глюки - поставь себе нормальный линукс и не мучайся.

anonymous ()

В глобальных настройках есть настройки клавиатуры, там настройки клавиатуры, потыкай там раскладки.

Zhbert ★★★★★ ()
Ответ на: комментарий от ilovewindows

Это автозамена, бывает проглядел.

anonymous ()

Так ты как раз правильную раскладку поставил, типографскую. Привыкни к ней, она лучше.

spqr ★★★ ()

Тьфу, машинописную.

spqr ★★★ ()

Установила попробовать

пруфпик?

// вам на форум убунты

anonymous ()

В убунте всегда поломана раскладка клавиатуры и переключалка. Это там хроническая болезнь.

Nxx ★★★★★ ()

Убунта пошла по пути третьегнома, знаки препинания слишком сложны для пользователя?
В настройках расскладки у тебя наверняка выбрано что-то необычное.

f1xmAn ★★★★★ ()

Запустите в консоли xev и попробуйте потыкать в шифт. Что-нибудть при этом вываливается в выхлоп? Если да, то что?

Axon ★★★★★ ()
Последнее исправление: Axon (всего исправлений: 1)
Ответ на: комментарий от TuxR

Спасибо. Заработало. Подскажите, пожалуйста, как сделать, чтоб при включении эти настройки автоматически запускались. Потому что каждый раз приходится в консоли набирать /usr/local/bin/setxkb и перезапускать все программы.

len4ik ()
Ответ на: комментарий от len4ik

Что за система? Ubuntu 12, Gnome 3?

 
sudo gedit /usr/local/bin/setxkb 
, туда скопировать
 
#!/bin/sh

setxkbmap -layout "us,ru"  -option "grp:caps_toggle"  -variant ",legacy"

потом
sudo chmod 755 /usr/local/bin/setxkb 
, чтобы разрешить исполнение. Потом добавить этот скрипт в автозапуск. Нашел описание, правда иероглифами написано: http://askubuntu.com/questions/37957/how-do-i-manage-applications-on-startup-...

Надо найти в настройках автозапуск приложений и добавить туда /usr/local/bin/setxkb

TuxR ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.