LINUX.ORG.RU

ATi Radeon + Compiz + Xfce4 + Debian

 , , , ,


0

1

Не работает Compiz в Debian Squeeze (Xfce4)

Видеокарта ATi Radeon (Какая точно, не скажу)

Вот вывод терминала на compiz --replace:

compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

Понял только последнее, что запустится Xfwm4

Пробовал по совету на одном из других форумов apt-get install fglrx и не помогло :-(

А для чего тебе Compiz?

toney ★★★★★ ()

А не из под рута ли Вы это запускаете?

tyakos ★★★ ()
Ответ на: комментарий от AITap

Моя видеокарта там не написана. Значит не поддерживается? :-(

У меня древняя ATI Mobility Radeon IGP354.

Nycteas ()
Ответ на: комментарий от Nycteas

Странно... В Ubuntu и Knoppix, где Compiz из коробки — все работает...

Nycteas ()
Ответ на: комментарий от Nycteas

Всё же, было бы не плохо если б вы показали /var/log/Xorg.0.log и вывод glxinfo. По крайней мере, для вас.

indaair ()
Ответ на: комментарий от tyakos

Все. Обновление установлено (удивительно, что ничего не перестало работать). А Compiz так и не появился :-(

Nycteas ()
Ответ на: комментарий от Nycteas

Ставил.

Быть того не может. С ним бы не работал драйвер radeon.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Нельзя ему бэкпорты, там каталист 12.3, в котором его карточка ЕМНИП не поддерживается.

leave ★★★★★ ()
Последнее исправление: leave (всего исправлений: 1)
Ответ на: комментарий от Nycteas

И что, поставилось? Настроилось? aticonfig делали?

AITap ★★★★★ ()

Удали fglrx, твоей карте он все равно не поможет.

lyrix87 ()
Ответ на: комментарий от AITap

(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.10.0,
[dri] but the kernel reports a version of 2.0.0.
[dri] If using legacy modesetting, upgrade your kernel.
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.

AITap ★★★★★ ()
Ответ на: комментарий от Nycteas

aptitude purge fglr-driver && reboot
И снова покажите /var/log/Xorg.0.log

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.