LINUX.ORG.RU

(Debian Squeeze) vs Compiz


0

1

Compiz не работает ни в какую!
Кто-нибудь сталкивался с такой проблемой? Что можно с этим сделать?

me@debnote:~$ compiz --replace
compiz (core) - Fatal: Software rendering detected.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

me@debnote:~/misc$ ./compiz-check 

Gathering information about your system...

 Distribution:          Debian GNU/Linux (6.0)
 Desktop environment:   GNOME
 Graphics chip:         ATI Technologies Inc Mobility Radeon HD 3400 Series
 Driver in use:         radeon
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [ OK ]

Ответ на: комментарий от Polugnom

Не помогло =(

me@debnote:~/misc$ ./compiz-check 

Gathering information about your system...

 Distribution:          Debian GNU/Linux (6.0)
 Desktop environment:   GNOME
 Graphics chip:         ATI Technologies Inc Mobility Radeon HD 3400 Series
 Driver in use:         fglrx
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [SKIP]

At least one check had to be skipped:
 Error: Unable to detect fglrx driver version in use. 

me@debnote:~$ compiz --replace
compiz (core) - Fatal: Software rendering detected.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager
me@debnote:~/misc$ lsmod | grep fglrx
fglrx                2186035  48 
me@debnote:~/misc$ lsmod | grep radeon
me@debnote:~/misc$ 

kermzyxer ()
Ответ на: комментарий от kermzyxer

>OpenGL vendor string: Brian Paul

OpenGL renderer string: Mesa X11

Проприетарный драйвер не стоит, должно быть не mesa а ati radeon

# apt-get install fglrx-glx fglrx-modules-dkms linux-headers

# aticonfig --initial

MyFreedom ★★★ ()

Возможно стоит подправить xorg.conf. Да, я знаю что совет из прошлого века, но иногда бывает полезно...

TheKnight ★★★ ()
Ответ на: комментарий от MyFreedom

Да, читал, только версию для squeeze. C xorg.conf разобрался: его надо было удалить и aticonfig сгенерировал его сам. Но это не помогло =(
Ускорение графики работет. В glxgears fps увеличилось в 10 раз.
Но compiz вылетает с той же ошибкой:

compiz (core) - Fatal: Software rendering detected.

kermzyxer ()
Ответ на: комментарий от kermzyxer

Нарыл в инете:

The display adapter is 01:00.0 VGA compatible controller: ATI Technologies Inc Mobilitiy Radeon HD 3400 Series

Surprisingly (or not ?), the radeonhd driver gave me a grey jittery screen. But it works with the ati driver. I can get KWin's compositing features through XRender, but no OpenGl with this driver.

Но в Ubuntu у меня работал compiz!

kermzyxer ()
Ответ на: комментарий от kermzyxer
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
#    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung"
    HorizSync       30.0 - 61.0
    VertRefresh     50.0 - 120.0
    Option         "DPMS"
EndSection# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce2 MX/MX 400"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
	Option	"AddARGBGLXVisuals"	"True"
    Option         "metamodes" "1024x768_75 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Это то, что сейчас у меня. Тебе собственно нужен только вот этот кусок:

Section "Module"
	Load	"glx"
EndSection
Возможно вместо модуля glx надо будет прописать AIGLX. Все это кстати легко ищется в яндексе...

TheKnight ★★★ ()
Ответ на: комментарий от kermzyxer

В Ubuntu много что веселого работает.. Но к сожалению не всегда правильно. И тогда там извращаться приходится даже порой больше чем под Debian.

TheKnight ★★★ ()
Ответ на: комментарий от kermzyxer

radeonhd мерт уже давно, у вас с самого начала все было нормально, скорее всего прошивок ядра нехаватало, и все бы заработало.

Novell-ch ★★★★★ ()
Ответ на: комментарий от kermzyxer

да потому что нужно завести что-то одно, и убедится что оно работает, или разобраться почему не работает, прыгать с одного на другое глупо.
удоли fglrx поставь месу, драйвер radeon, kernel-firmware или как-то так, и читай логи dmesg и xorg.0.log

Novell-ch ★★★★★ ()
Ответ на: комментарий от kermzyxer

Собственно у меня была такая же проблема. Причем на Убунте. Секцию загрузкой GLX модуля уже прописывал? Скинь полученный для fglrx'а xorg.conf.

TheKnight ★★★ ()
Ответ на: комментарий от Novell-ch

kernel-firmware или как-то так

метапакет называется firmware-linux, зависит от firmware-linux-free и firmware-linux-nonfree

fluorite ★★★★★ ()

попробуй добавить в xorg

Section "Extensions"
        Option "Composite" "enable"
EndSection

xroff ()
Ответ на: комментарий от Novell-ch

Снес. Поставил.
Отрывок из dmesg:

[   17.820191] [drm] Initialized drm 1.1.0 20060810
[   17.922670] [drm] radeon kernel modesetting enabled.
[   17.922711] radeon 0000:01:00.0: setting latency timer to 64
[   17.923654] [drm] radeon: Initializing kernel modesetting.
[   17.923731] [drm] register mmio base: 0xFDDF0000
[   17.923733] [drm] register mmio size: 65536
[   17.923835] ATOM BIOS: PackardBell
[   17.923854] [drm] Clocks initialized !
[   17.924923] [drm] Detected VRAM RAM=256M, BAR=256M
[   17.924926] [drm] RAM width 64bits DDR
[   17.925303] [TTM] Zone  kernel: Available graphics memory: 437310 kiB.
[   17.925305] [TTM] Zone highmem: Available graphics memory: 1557378 kiB.
[   17.925320] [drm] radeon: 256M of VRAM memory ready
[   17.925322] [drm] radeon: 512M of GTT memory ready.
[   17.925365] radeon 0000:01:00.0: irq 31 for MSI/MSI-X
[   17.925371] radeon 0000:01:00.0: radeon: using MSI.
[   17.925395] [drm] radeon: irq initialized.
[   17.925398] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   17.925595] [drm] Loading RV620 Microcode
[   17.925598] platform radeon_cp.0: firmware: requesting radeon/RV620_pfp.bin
[   18.014900] platform radeon_cp.0: firmware: requesting radeon/RV620_me.bin
[   18.029639] Bluetooth: L2CAP ver 2.14
[   18.029641] Bluetooth: L2CAP socket layer initialized
[   18.053299] platform radeon_cp.0: firmware: requesting radeon/R600_rlc.bin
[   18.087154] Bluetooth: RFCOMM TTY layer initialized
[   18.087157] Bluetooth: RFCOMM socket layer initialized
[   18.087159] Bluetooth: RFCOMM ver 1.11
[   18.138427] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   18.138430] Bluetooth: BNEP filters: protocol multicast
[   18.150682] [drm] ring test succeeded in 1 usecs
[   18.150810] [drm] radeon: ib pool ready.
[   18.150873] [drm] ib test succeeded in 0 usecs
[   18.150876] [drm] Enabling audio support
[   18.151023] [drm] Radeon Display Connectors
[   18.151025] [drm] Connector 0:
[   18.151027] [drm]   LVDS
[   18.151029] [drm]   DDC: 0x7f68 0x7f68 0x7f6c 0x7f6c 0x7f70 0x7f70 0x7f74 0x7f74
[   18.151032] [drm]   Encoders:
[   18.151033] [drm]     LCD1: INTERNAL_KLDSCP_LVTMA
[   18.151035] [drm] Connector 1:
[   18.151036] [drm]   HDMI-A
[   18.151038] [drm]   HPD1
[   18.151040] [drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[   18.151042] [drm]   Encoders:
[   18.151043] [drm]     DFP2: INTERNAL_UNIPHY
[   18.151045] [drm] Connector 2:
[   18.151046] [drm]   DVI-I
[   18.151047] [drm]   HPD3
[   18.151050] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[   18.151052] [drm]   Encoders:
[   18.151053] [drm]     DFP1: INTERNAL_UNIPHY
[   18.151055] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[   18.165917] Bridge firewalling registered
[   18.238838] Bluetooth: SCO (Voice Link) ver 0.6
[   18.238840] Bluetooth: SCO socket layer initialized
[   18.282508] [drm] fb mappable at 0xD0141000
[   18.282511] [drm] vram apper at 0xD0000000
[   18.282512] [drm] size 4096000
[   18.282514] [drm] fb depth is 24
[   18.282515] [drm]    pitch is 5120
[   18.282695] Console: switching to colour frame buffer device 160x50
[   18.282701] fb0: radeondrmfb frame buffer device
[   18.282703] registered panic notifier
[   18.282708] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0

kermzyxer ()
Ответ на: комментарий от TheKnight

Не могу, так как fglrx снес, он xorg.conf сам сочинял. GLX прописывал, но он и так грузиться - видно по логу.

kermzyxer ()
Ответ на: комментарий от Novell-ch

Из xorg.0.log:

...
(--) PCI:*(0:1:0:0) 1002:95c4:1631:c11c ATI Technologies Inc Mobility Radeon HD 3400 Series rev 0, Mem @ 0xd0000000/268435456, 0xfddf0000/65536, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.1.0
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(==) Matched ati as autoconfigured driver 0
(==) Matched vesa as autoconfigured driver 1
(==) Matched fbdev as autoconfigured driver 2
(==) Assigned the driver to the xf86ConfigLayout
(II) LoadModule: "ati"
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Module ati: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 6.13.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "radeon"
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 6.13.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 2.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
        compiled for 1.7.6.901, module version = 0.4.2
        ABI class: X.Org Video Driver, version 6.0
(II) RADEON: Driver for ATI Radeon chipsets:
        ...
        
        Тут длинный список поддерживаемых карт, моя есть.

        ...
        CEDAR

kermzyxer ()
Ответ на: комментарий от kermzyxer

Продолжение.
[code]
(II) VESA: driver for VESA chipsets: vesa
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 01@00:00:0
(II) [KMS] drm report modesetting isn't supported.
(WW) Falling back to old probe method for vesa
(WW) Falling back to old probe method for fbdev
(II) Loading sub module «fbdevhw»
(II) LoadModule: «fbdevhw»
(II) Loading /usr/lib/xorg/modules/linux/libfbdevhw.so
(II) Module fbdevhw: vendor=«X.Org Foundation»
compiled for 1.7.7, module version = 0.0.2
ABI class: X.Org Video Driver, version 6.0
(EE) open /dev/fb0: No such file or directory
(II) RADEON(0): TOTO SAYS 00000000fddf0000
(II) RADEON(0): MMIO registers at 0x00000000fddf0000: size 64KB
(II) RADEON(0): PCI bus 1 card 0 func 0
(II) RADEON(0): Creating default Display subsection in Screen section
«Default Screen Section» for depth/fbbpp 24/32
(==) RADEON(0): Depth 24, (--) framebuffer bpp 32
(II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) RADEON(0): Default visual is TrueColor
(II) Loading sub module «vgahw»
(II) LoadModule: «vgahw»
(II) Loading /usr/lib/xorg/modules/libvgahw.so
(II) Module vgahw: vendor=«X.Org Foundation»
compiled for 1.7.7, module version = 0.1.0
ABI class: X.Org Video Driver, version 6.0
(II) RADEON(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(==) RADEON(0): RGB weight 888
(II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
(--) RADEON(0): Chipset: «ATI Mobility Radeon HD 3400 Series» (ChipID = 0x95c4)
(--) RADEON(0): Linear framebuffer at 0x00000000d0000000
(II) RADEON(0): PCIE card detected
(II) Loading sub module «int10»
(II) LoadModule: «int10»
(II) Loading /usr/lib/xorg/modules/libint10.so

(II) Module int10: vendor=«X.Org Foundation»
compiled for 1.7.7, module version = 1.0.0
ABI class: X.Org Video Driver, version 6.0
(II) RADEON(0): initializing int10
(II) RADEON(0): Primary V_BIOS segment is: 0xc000
(II) RADEON(0): ATOM BIOS detected
(II) RADEON(0): ATOM BIOS Rom:
SubsystemVendorID: 0x1631 SubsystemID: 0xc10c
IOBaseAddress: 0xc000
Filename: BR28697.008
BIOS Bootup Message:
PackardBell H13VV M82SCEXT DDR2 500e/500m ASID:A23335.016$

(II) RADEON(0): Framebuffer space used by Firmware (kb): 20
(II) RADEON(0): Start of VRAM area used by Firmware: 0xfffb000
(II) RADEON(0): AtomBIOS requests 20kB of VRAM scratch space
(II) RADEON(0): AtomBIOS VRAM scratch base: 0xfffb000
(II) RADEON(0): Cannot get VRAM scratch space. Allocating in main memory instead
(II) RADEON(0): Default Engine Clock: 500000
(II) RADEON(0): Default Memory Clock: 500000
(II) RADEON(0): Maximum Pixel ClockPLL Frequency Output: 1200000
(II) RADEON(0): Minimum Pixel ClockPLL Frequency Output: 0
(II) RADEON(0): Maximum Pixel ClockPLL Frequency Input: 13500
(II) RADEON(0): Minimum Pixel ClockPLL Frequency Input: 1000
(II) RADEON(0): Maximum Pixel Clock: 400000
(II) RADEON(0): Reference Clock: 27000
drmOpenDevice: node name is /dev/dri/card0
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: drmOpenMinor returns 11
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.0.0.[dri] If using legacy modesetting, upgrade your kernel.
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.
(II) RADEON(0): using shadow framebuffer
(II) Loading sub module «shadow»
(II) LoadModule: «shadow»
(II) Loading /usr/lib/xorg/modules/libshadow.so
(II) Module shadow: vendor=«X.Org Foundation»
compiled for 1.7.7, module version = 1.1.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) RADEON(0): Detected total video RAM=262144K, accessible=262144K (PCI BAR=262144K)
(--) RADEON(0): Mapped VideoRAM: 262144 kByte (64 bit DDR SDRAM)
(II) RADEON(0): Color tiling disabled
(II) Loading sub module «ddc»
(II) LoadModule: «ddc»
(II) Module «ddc» already built-in
(II) Loading sub module «i2c»
(II) LoadModule: «i2c»
(II) Module «i2c» already built-in
(II) RADEON(0): PLL parameters: rf=2700 rd=12 min=90000 max=120000; xclk=40000
(WW) RADEON(0): LVDS Info:
XRes: 1280, YRes: 800, DotClock: 71000
HBlank: 160, HOverPlus: 48, HSyncWidth: 32
VBlank: 23, VOverPlus: 3, VSyncWidth: 6
(II) RADEON(0): Output LVDS has no monitor section
(II) RADEON(0): Output HDMI-0 has no monitor section
(II) RADEON(0): I2C bus «HDMI-0» initialized.
(II) RADEON(0): Output DVI-0 has no monitor section
(II) RADEON(0): I2C bus «DVI-0» initialized.
(II) RADEON(0): Port0:
XRANDR name: LVDS
Connector: LVDS
LCD1: INTERNAL_KLDSCP_LVTMA
DDC reg: 0x0
(II) RADEON(0): Port1:
XRANDR name: HDMI-0
Connector: HDMI-A
DFP2: INTERNAL_UNIPHY
DDC reg: 0x7e50
(II) RADEON(0): Port2:
XRANDR name: DVI-0
Connector: DVI-I
CRT1: INTERNAL_KLDSCP_DAC1
DFP1: INTERNAL_UNIPHY
DDC reg: 0x7e40
(II) RADEON(0): Output: LVDS, Detected Monitor Type: 2
finished output detect: 0
(II) RADEON(0): I2C device «HDMI-0:ddc2» registered at address 0xA0.
(II) RADEON(0): Output: HDMI-0, Detected Monitor Type: 0
finished output detect: 1
(II) RADEON(0): I2C device «DVI-0:ddc2» registered at address 0xA0.
Dac detection success
(II) RADEON(0): Output: DVI-0, Detected Monitor Type: 0
Unhandled monitor type 0
finished output detect: 2
finished all detect
...
[/code]

kermzyxer ()
Ответ на: комментарий от kermzyxer

[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.0.0.[dri] If using legacy modesetting, upgrade your kernel.
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.

Эммм. Кажется, оно.

kermzyxer ()
Ответ на: комментарий от Novell-ch
me@debnote:~$ glxinfo 
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: Brian Paul
server glx version string: 1.4 Mesa 7.7.1
me@debnote:~$ compiz --replace
compiz (core) - Fatal: Software rendering detected.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager
kermzyxer ()
Ответ на: комментарий от kermzyxer

(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
и т.д и т.п
возможно имеет смысл загрузится с nomodeset, потому что для нормально 3д kms все слишком старое, ну или попытаться найти ядро,libdrm поновее ну и месу желательно.

Novell-ch ★★★★★ ()
Ответ на: комментарий от kermzyxer

dmesg и xorg.log без kms, может kms включен в инитрд? лучше всего ядру передать nomodeset

Novell-ch ★★★★★ ()

ТС - показывай иксоконфиг
атиконфигурялка искаропки отключает композит - отсюда растут ноги
короче - конфиг!

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

Нету у меня сейчас xorg.conf
Попробую переустановить дистрибутив, изначально выбрав 'установку с гномом'. Завтра напишу, что из этого получилось.

kermzyxer ()
Ответ на: комментарий от megabaks

Все! Переустановил дистрибутив, проделал все с начала - Compiz заработал!
Сейчас сижу на Radeon, попробую поставить несвободные дрова.
----------------------------------------------------------------------------
Спасибо огромное всем, кто помогал!

kermzyxer ()
Ответ на: комментарий от kermzyxer

fglrx поставил, но по какой-то причине с несвободными дровами compiz работал очень не стабильно. Хотя fps в glxgears поднялось с 800 до 2800 Выпилил fglrx, запилил radeon.

kermzyxer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.