LINUX.ORG.RU

Debian Приоритет звуковой карты.


0

1

В системе используется, точней должна использоваться дискретная звуковая карта

# lspci | grep -i audio
02:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device [Radeon HD 2600 Series]
03:07.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
Должно использоватся второе устройство, а используется первое, которое на самом деле, как видно, никакая не аудиокарта(просто hdm естьi ) Тут

# lsmod | grep snd
snd_ice1724            72984  1 
snd_seq_midi            3576  0 
snd_seq_midi_event      3684  1 snd_seq_midi
snd_rawmidi            12513  2 snd_ice1724,snd_seq_midi
snd_ice17xx_ak4xxx      1700  1 snd_ice1724
snd_ac97_codec         79152  1 snd_ice1724
snd_hda_codec_atihdmi     1687  1 
ac97_bus                 710  1 snd_ac97_codec
snd_ak4xxx_adda         5131  2 snd_ice1724,snd_ice17xx_ak4xxx
snd_ak4114              5177  1 snd_ice1724
snd_hda_intel          16823  0 
snd_pt2258              1992  1 snd_ice1724
snd_hda_codec          46062  2 snd_hda_codec_atihdmi,snd_hda_intel
snd_hwdep               4054  1 snd_hda_codec
snd_i2c                 2594  2 snd_ice1724,snd_pt2258
snd_pcm                47222  5 snd_ice1724,snd_ac97_codec,snd_ak4114,snd_hda_intel,snd_hda_codec
snd_seq                35463  2 snd_seq_midi,snd_seq_midi_event
snd_timer              12270  2 snd_pcm,snd_seq
snd_seq_device          3673  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    34415  16 snd_ice1724,snd_rawmidi,snd_ac97_codec,snd_ak4xxx_adda,snd_ak4114,snd_hda_intel,snd_pt2258,snd_hda_codec,snd_hwdep,snd_i2c,snd_pcm,snd_seq,snd_timer,snd_seq_device
snd_page_alloc          5045  2 snd_hda_intel,snd_pcm
soundcore               3450  1 snd
Она , как понимаю, имеет вид snd_ice1724 Прописывание в /etc/modprobe.d/alsa-base.conf options snd_ice1724 index=0 ничего хорошего не сделало, т к alsamixer вообще заявил, что никаких аудиокарт не видит. Что делать, как быть?

★★★

echo 'blacklist snd_hda_intel' >> /etc/modprobe.d/alsa-base-blacklist.conf

У меня так работает.

anonymous ()

для alsa можно прописать в ~/asoundrc строчку
pcm.!default front:SB
Вместо front:SB подставь нужное устройство из выхлопа `aplay -L`

nu11 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.