LINUX.ORG.RU

Поломались дополнительные клавиши на Microsoft Natural Ergonomic Keyboard 4000

 


0

1

Неожиданно перестали работать все допклавиши, плюс устройство, на котором она висит, непрерывно посылает вот такое событие:

Event: time 1339171223.353160, -------------- SYN_REPORT ------------
Event: time 1339171223.386526, type 1 (EV_KEY), code 158 (KEY_BACK), value 2
Ядро обновлял, но уже после того, как это произошло. Иксы обновлялись неделю назад, после этого, вроде, ещё работало.
Что это может быть за фигня?

★★★★★

Что это может быть за фигня?

Ломали уже один раз. Отлавливал с помощью showkey сканкоды и приклеивал к функциям обратно.

Deleted ()

Похоже, с этой клавиатурой действительно хрен знает что творится. У меня, например, она любит отрубаться при скачке напряжения на PCI, вызванном включением/выключением акустики. И пока иксы не перезапустишь, ничего… Зато обычная «доска» работает себе.

Жалко, конечно: я тоже не люблю M$, но эта клавиатура - действительно шедевр. А разработчики иксов настроены уж очень категорично…

Eddy_Em ☆☆☆☆☆ ()

Странно, всё как-то само прошло после ребута. Мистика.

Axon ★★★★★ ()
Ответ на: комментарий от Axon

Странно, всё как-то само прошло после ребута. Linux.

Пофиксил =)

VirRaa ★★★ ()
Ответ на: комментарий от Eddy_Em

А у меня все работает. В GNOME все было отлично изкоробки, но Xfce ни в какую не подхватывает мультимедийные кнопки (Play/Pause).

ArtKun ★★★★★ ()
Ответ на: комментарий от Eddy_Em

никаких проблем вообще не было за 2 года постоянного использования

lazyklimm ★★★★★ ()
Ответ на: комментарий от Eddy_Em

А разработчики иксов настроены уж очень категорично…

А что они говорят?

HerrWeigel ★★★★ ()
Ответ на: комментарий от HerrWeigel

Ничего не говорят, но, похоже, на M$ зуб точат, раз эта клава в иксах себя так хреново чувствует.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от ArtKun

У меня-то все клавиши работают, а «zoom» я через xdotool настроил. Но вот при скачках напряжения (когда включаю/выключаю колонки) отрубается то клава, то мыша. И без перезапуска иксов не включаются (даже если в другой порт запихаешь).

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Eddy_Em

Сетевого фильтра, что ли, нет, или БП говно, или мать...? Что-то здесь не так :)

А не удавалось перепрограммировать zoom на scroll?

ArtKun ★★★★★ ()
Ответ на: комментарий от ArtKun

Материнка, наверное, хреновая. Фильтр мне не нужен: у меня ИБП. Колонки тоже в ИБП включаю. А USB отрубаются из-за экстратоков при включении/выключении колонок (через звуковушку). Раньше такого не было.

А не удавалось перепрограммировать zoom на scroll?

А он у меня и работает в качестве скролла: эмулирует колесо мыши.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от VirRaa

Странно, всё как-то само прошло после ребута. Arch.

DoubleFix.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.