LINUX.ORG.RU

Проблема с сетью

 , ,


0

1

Всем привет, после выхода SystemRescueCD 2.7.0 обнаружил, что в x64 варианте с ключами docache и nonm система нормально устанавливает pptp соединение (провайдер билайн) но http, ftp, rsync соединения отваливаются по тайм-ауту, при этом пинги проходят без потерь (отсюда предполагаю, что проблема проявляется только в протоколах транспортного уровня*). Netstat показывает, что соединения находятся в состоянии established. При этом в системе не загруженной в память и с NetworkManager-ом ничего подобного не наблюдается. Вообще-то ерунда, но сегодня столкнулся с подобной ситуацией на свеже установленной gentoo (~amd64 ядро 3.3.5 pptpclient 1.7.2), что уже не приятно =). Хотел узнать не сталкивался ли кто-либо с подобной проблемой?
* С предположением о протоколах транспортного уровня ошибаюсь, ведь доменные имена при пингах разрешаются корректно

Ответ на: MTU? от StalluManu

Надо играться с MTU на ppp0. Причём в сторону уменьшения. Если компьютер работает роутером - то требуется также небольшой тюнинг iptables.

Deleted ()
Ответ на: комментарий от Deleted

Повторно прошелся ifconfig-ом по интерфейсу ppp0, меняя параметр mtu от 1500 до 650 с шагом 50, к сожалению ситуация не изменилась. iptables пока не установлен, машина десктопная.

Может все же не mtu? =)

StalluManu ()
Ответ на: комментарий от StalluManu

Может и не в MTU. Тем не менее, на pptp-интерфейсе, трафик которого идёт через ethernet не может быть MTU == 1500.

Deleted ()
Ответ на: комментарий от Deleted

Все же MTU

Приношу извинения за излишний скепсис к вашему предположению, дело действительно было в значении MTU. После установления pptp соединения MTU для eth0 менялось на 568. После возвращения его в стандартные для ethernet полторы тыщи проблема исчезла. Ранее менял значение mtu для eth0 до подключения, поэтому эту ерунду проглядел.

StalluManu ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.