LINUX.ORG.RU

MPlayer(2) в Gentoo

 , , ,


0

2

Как сейчас обстоит дело с поддержкой vaapi плееров? Судя по багзилле, в MPlayer2 её нет, так что, видимо, придётся использовать просто MPlayer(тот самый, который с паршивыми seek, pause и собственными(глючными) реализациями libass, libdvdnav и ffmpeg).

Кто-нибудь здесь мейнтейнит эти ебилды? Или, может, можно в ручном режиме наложить патч на 9999-ебилд в полуавтоматическом режиме(может, даже на второй MPlayer)? Ну и хотелось бы услышать отзывы владельцев, может, уже рациональнее использовать давно смерженную в основное древо многопоточность(бывший ffmpeg-mt)?

Да, кстати, поддержка vaapi есть в ffmpeg, который использует MPlayer2, но, видимо, этого мало, т.к. в выводе -vo help vaapi нет.

★★★★★

Что такое vaapi? У меня mplayer2, как проверить его наличие?

vurdalak ★★★★★ ()

У меня всё наоборот: у mplayer2 есть USE-флаг vaapi, у mplayer нет. Ну и, разумеется, mplayer2, собранный с USE=vaapi и запущенный с -vo vaapi, прекрасно использует его, что видно из выхлопа в консоли.

anonymous ()

и собственными(глючными) реализациями libass, libdvdnav и ffmpeg)

Что ты курил?

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

А теперь внимательно посмотри на багзиллу оригинального MPlayer'а. Или ты думаешь, что разработчики MPlayer2 просто так используют внешние ffmpeg и остальные либы?

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

А теперь внимательно посмотри на configure оригинального mplayer'a. Особенно на строчки типа cd ffmpeg && git pull.

redgremlin ★★★★★ ()

Нужен ebuild с названием mplayer-vaapi, либо плеер VLC. Там VAAPI уже поддерживается. Но у меня не работает без «LIBVA_DRIVER_NAME=xvba vlc» или «LIBVA_DRIVER_NAME=xvba mplayer» после какой-то из версий или проприетарного драйвера ATi, или VA-API.

XvBA брать или отсюда, или отсюда. По первой ссылке бинарник, его нужно положить в каталог /usr/lib/va/drivers/, по второй ссылке - исходник. ebuild здесь. Запускать командой:

LIBVA_DRIVER_NAME=xvba mplayer-vaapi -vo vaapi:gl -va vaapi faileg.mkv

Либо настроить SMPlayer по какому-либо руководству.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Во-первых, XvBA мне не нужен, во-вторых, ебилд древний.

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

Это для самого нового патча mplayer-vaapi. Тогда не нужно устанавливать XvBA, нужно ядро 2.6.35 или старше.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от redgremlin

И это, по-твоему, говорит об отсутствии встроенного ffmpeg или отдельных его кусков?

Впрочем, замечательно, если они выкинули наконец и этот велосипед и MPlayer можно использовать с ffmpeg из транка, не имея никаких проблем с Hi10P и т.п.

Впрочем, это не отменяет убогой перемотки и остальных недостатков.

Lighting ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Мне и так не нужны радеоновские велосипеды. А вопрос состоял в том, можно ли использовать эти патчи с версией из транка.

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

В ядре 2.6.35 добавлено ускорение для Intel. Попробую наложить патчи.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Lighting

И это, по-твоему, говорит об отсутствии встроенного ffmpeg или отдельных его кусков?

Вполне. Хотя можешь svn log глянуть, где-то двухлетней давности коммит был с дропом встроенного ffmpeg'а.

Впрочем, это не отменяет убогой перемотки и остальных недостатков.

И толку с этой крутой перемотки, если у mplayer2 полтора разработчика и в плане основной задачи - проигрывания видео, они уже года на 1.5 минимум от mplayer'а отстали. Почитай на досуге логи коммитов и того и другого за последний год, скажем.

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

Ну и в чём же выражается отставание в разработке?

Lighting ★★★★★ ()
Ответ на: комментарий от Lighting

У mplayer'а лучше поддержка разных кодеков и их вариаций, профилей, демуксеров и т.д., больше ошибок исправлено, как следствие, намного меньше проблемных видео, кривых субтитров, внезапных крешей и прочего.

redgremlin ★★★★★ ()
Ответ на: комментарий от anonymous

Гонишь. Нет в mplayer2 пока что vaapi, в mplayer есть.

Deleted ()
Ответ на: комментарий от Lighting

Впрочем, это не отменяет убогой перемотки

Разве в mplayer это не настраивается?

Deleted ()
Ответ на: комментарий от anonymous

То что нужно, спасибо. Теперь не придётся собирать версию из git'а в /opt и морочиться с package.provided.

Lighting ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.