LINUX.ORG.RU

urxvt, проблемы с кириллицей


0

1

Привет,

после установки awesome решил в качестве эмулятора терминала использовать urxvt, но столкнулся с тем, что я не могу печатать кириллицей, хотя она и отображается. Для сравнения, в gnome-terminal все работает.

Вот мой .Xdefaults: http://paste.debian.net/157958/

Вывод locale: http://paste.debian.net/157960/

Подскажите, пожалуйста, как исправить данную проблему.

не могу печатать кириллицей

А что получается на выводе?

У меня:

 rxvt-unicode (urxvt) v9.15 - released: 2012-01-21
В ~/.Xdefaults даже нет упоминаний таких как:
urxvt*utf8: 1
urxvt*locale: 1

И все работает.

kitar ★★★★★ ()

если просто вставить кириллицу - все нормально?

в других программах ввод нормально работает?

lazyklimm ★★★★★ ()
Ответ на: комментарий от kitar

Просто ничего не печатается.

$ urxvt --help
rxvt-unicode (urxvt) v9.14 - released: 2011-12-21
options: perl,xft,styles,combining,blink,iso14755,unicode3,encodings=eu+vn+jp+jp-ext+kr+zh+zh-ext,fade,transparent,tint,pixbuf,XIM,frills,selectionscrolling,wheel,slipwheel,smart-resize,cursorBlink,pointerBlank,scrollbars=plain+rxvt+NeXT+xterm
DesertFox ()
Ответ на: комментарий от lazyklimm

Да, копипаст кириллицы работает. Так пока и выкручаваюсь :) В других программах такого бага замечено не было. Правда кроме xterm. Там кириллица и не печатается и выводится кракозябрами.

DesertFox ()

Да нет у меня никаких проблем с кириллицей.

urxvt ★★★★★ ()
Ответ на: комментарий от DesertFox

а зачем вообще в терминале кириллица?

по моему единственный приложения которые требуют ввод на русском это - браузер, офис и всякие im.

ktk ★★★★ ()
Ответ на: комментарий от DesertFox

во-первых, переименуй .Xdefaults в ~/.Xresources(уже лет 5 точно как устарело), во-вторых, из настроек для urxvt оставь только шрифт (лучше всего xft-шный, с ним меньше проблем). xrdb -load ~/.Xresources и попробуй снова

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

(лучше всего xft-шный, с ним меньше проблем)

Как я понимаю это означает, что нужно добавить «xft:» перед описанием шрифта. Если так, то не помогло.

xrdb -load ~/.Xresources

Тоже не помогло

DesertFox ()
Ответ на: комментарий от ktk

Должна быть и точка. Консольные бывают почтовые клиенты, rss-ридеры, плееры, те же im и файлменеджеры.

Или все файлы именовать транслитом?

Hoodoo ★★★★★ ()

Вообще странно, ничего особо подозрительного навскидку не вижу.

А что у тебя заведует переключением раскладок, может быть, оно косячит? setxkbmap -model pc104 -layout us,ru -variant winkeys -option grp:ctrl_shift_toggle,grp_led:scroll

Hoodoo ★★★★★ ()
Ответ на: комментарий от Hoodoo

Для раскладки использую следующую команду: setxkbmap «us,ru,ua,us» -variant «dvp,winkeys,unicode,» -model pc105 -option «grp:menutoggle,grp_led:scroll,compose:rwin,ctrl:nocaps» Ввел ту строку, что ты написал — тоже самое.

Еще я использую kbdd для того чтобы раскладки сохранялись отдельно для каждого окна. Его выключение ничего не изменило.

До того как я поставил awesome у меня сначало был GNOME 2, а потом GNOME 3. Может они как-то могли повлиять.

DesertFox ()
Ответ на: комментарий от LMD

ОК. Мог забыть. !setxk потому что, либо засунуто в настройки окноменеджера.

Hoodoo ★★★★★ ()
Ответ на: комментарий от Linez

Может именно из-за него у меня всё работает и с xdefaults.

«есть такое матерное слово - легаси»

lazyklimm ★★★★★ ()
Ответ на: комментарий от Pupizoid

системопроблемы, чо. Если бы urxvt САМ по доброте душевной не поддерживал ~/.Xdefaults у тебя вообще ничего бы не работало

lazyklimm ★★★★★ ()
Ответ на: комментарий от DesertFox

.Xdefaults

URxvt.font:                     [codeset=UTF-8]xft:Terminus:pixelsize=20
URxvt.boldFont:                 [codeset=UTF-8]xft:Terminus:bold:pixelsize=20
URxvt.italicFont:               [codeset=UTF-8]xft:Terminus:italic:pixelsize=20
URxvt.boldItalicFont:           [codeset=UTF-8]xft:Terminus:bold:italic:pixelsize=20
URxvt.background:               black
URxvt.foreground:               gray
URxvt.loginShell:               True
URxvt.scrollBar:                False
URxvt.scrollBar_right:          True
URxvt.saveLines:                1000
URxvt.termName:                 rxvt
URxvt.mouseWheelScrollPage:     False
URxvt.geometry:                 80x25
URxvt.perl-ext-common:          default,tabbed
URxvt.tabbed.tabbar-fg:         8
URxvt.tabbed.tabbar-bg:         0
URxvt.tabbed.tab-fg:            4
URxvt.tabbed.tab-bg:            0

???

Neksys ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.