LINUX.ORG.RU

PCLinuxOS. Не удаётся обновиться...


0

1

Привет всем!!!

Сейчас хотел обновить систему через Synaptic. Он нашёл обновления, но не обновиться не даёт, затемнена кнопка «Apply». Когда попытался сделать обновление вручную вылетела ошибка

--------------------------------------------------------------------------------------------

addlocale: Depends: rpmlib(PayloadIsLzma) (<=4.4.6-1) but it is not installable

--------------------------------------------------------------------------------------------

Посмотрел, и впрямь её нет. Нет ни в установленных, ни в известных пакетах, в репозитарии отмечены main updates nonfree games kde4.

Как разрулить ситуацию?

Или только делать обновление с диска?

Заранее всем спасибо!!!



Ответ на: комментарий от lmtea

rpm http://gnustep.ethz.ch/mirror/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4

rpm [PCLinuxOS] http://distro.ibiblio.org/pclinuxos/megagames/apt/ pclinuxos/2010 megagames

rpm http://distro.ibiblio.org/pclinuxos/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4

rpm http://distrib-coffee.ipsl.jussieu.fr/pub/linux/pclinuxos/apt/ pclinuxos/2010 main updates nonfree games kde4

rpm http://pclos.camors.org/apt/ pclinuxos/2010 main updates nonfree games kde4

alfer ()
Ответ на: комментарий от lmtea

Я правильно понял этот файл надо скачать и установить. Но как если версия RPM не та...

alfer ()
Ответ на: комментарий от alfer

То есть пакеты вообще не ставятся? Или вас беспокоит номер версии? Если только номер, то поставить попробуйте, поверьте, а потом уже пишите. Если не ставятся, то давайте поподробнее: кем и как не ставится?

lmtea ()
Ответ на: комментарий от lmtea

Устанавливаю пакеты и обновляю систему через Synaptic. Сейчас сделал следующее - выбрал пакеты которые у меня не стояли и сказал их установить. Без проблем, поставился маркер для установки и открылась кнопка Apply. Если же я делаю «Reload package information» «Mark all upgrade» то кнопка Apply остаётся серой. Тогда я нахожу пакет помеченный для обновления, и повторно пытаюсь его пометить для обновления. Вот тут и вылезает ошибка

--------------------------------------------------------------------------------------------

addlocale: Depends: rpmlib(PayloadIsLzma) (<=4.4.6-1) but it is not installable

--------------------------------------------------------------------------------------------

alfer ()
Ответ на: комментарий от alfer

Я не выспался наверно, не понял. Вы тот пакет, на который ссылка, скачали и вручную поставили?

lmtea ()
Ответ на: комментарий от lmtea

Если Вы про addlocale, то нет. Он есть в системе и я хочу его штатно обновить. Такая песня с браузерами и т.д....

alfer ()
Ответ на: комментарий от alfer

Что-то я туплю сегодня, кого в репах нет-то, addlocale или rpmlib?

lmtea ()
Ответ на: комментарий от lmtea

Даже не знаю что сказать по этому поводу... addlocale в репах есть, ибо он хочет обновиться. А вот rpmlib Synaptic не может найти. Хотя странно, как всё до этого работало????

Может было обновление rpm? Synaptic требует <=4.4.6-1, а в системе стоит RPM version 4.4.6. Если это так, то как обновить rpm?

alfer ()
Ответ на: комментарий от alfer

Я ж вам кинул ссылку на пакет rpmlib. Попробуйте поставить именно этот пакет, который лежит по ссылке, не из репов. Если будет ругаться на зависимости, подключите репозиторий http://distro.ibiblio.org/pclinuxos/pclinuxos/apt pclinuxos/2010 unstable и поставить оттуда

lmtea ()
Ответ на: комментарий от lmtea

Обновил rpm из нового репозитария. Версия 4.4.8. Но вот незадача - после перезагрузки вижу только черное окно. Что-то поломалось. В логах Х ничего нет. Бум дальше смотреть.....

alfer ()
Ответ на: комментарий от alfer

Победил. Всё заработало кроме Synaptic. Выдается ошибка

E: could not create RPM database iterator

alfer ()
Ответ на: комментарий от alfer

Ну, в RPM я не очень смыслю, больше в dpkg, но подозреваю, что что-то надо переконфигурировать. Вот только что?

lmtea ()
Ответ на: комментарий от lmtea

Я нашёл кое-что в нете. Надо было удалить старые базы, и сделать ребьюлд, как по русски не знаю. Не помогло. Утром подниму тему...

alfer ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.