LINUX.ORG.RU

.emacs autoload 'global-whitespace-mode


0

1

Всем доброго времени суток.

Решил сделать emacs своим штатным редактором исходников. В процессе настройки возникла проблема: Есть так называемый режим global-whitespace-mode, включает режим отображения пробелов и табов, для меня оч удобная и нужная вещь! Из интерактивного режима через M-x включается Повесил на горячую клавишу (global-set-key [f7] 'global-whitespace-mode) - работает.

Но мне нужно что бы автоматом при открытии ЛЮБОГО файла этот режим был активен. Как я только не пробовал (require 'whitespace)

(setq global-whitespace-mode t)

(autoload 'global-whitespace-mode «whitespace» «global-whitespace-mode ON» t) (autoload 'whitespace-mode «whitespace» «Toggle whitespace visualization.» t)

(autoload 'whitespace-toggle-options «whitespace» «Toggle local `whitespace-mode' options.» t)

И ничего, автоматом не хочет подрубать режим!!!

EMACSом недавно пользоваться начал. видимо чего то не понимаю, Может кто подскажет чего именно я не правильно делаю ?

Ответ на: комментарий от Array

Сделал, всё заработало )) Конфигуратор сам всё прописал.

Оказалось нужно было так прописать .emacs

(custom-set-variables '(global-whitespace-mode t)) (custom-set-faces )

Спасибо )

firstpilotpirks ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.