LINUX.ORG.RU

Раскладки в LXDE


0

1

После экспериментов с раскладками в LXDE на Fedora перезагрузился и шрифт по умолчанию стал русский. Т.е. и пароль-то не ввести, а раскладки не меняются до входа в систему! Как исправить это?


Выйди в консоль, убей иксы, залогинься и выполни startx. Потом выполни все действия наоборот, чтобы раскладка по умолчанию стала нормальной.

mopsene ★★★ ()
Ответ на: комментарий от mopsene

Потом выполни все действия наоборот

Которые ты совершал, до того, как раскладка по умолчанию стала русской. Извиняюсь за непонятные формулировки.

mopsene ★★★ ()
Ответ на: комментарий от mopsene

Еслиб я точно помнил подробно. Я хотел добавить дополнительные раскладки на нужные мне языки.. а сначала оказался один английский чего-то. Пожже уже прочитал, что в LXDE с этим проблемно. Видимо при добавлении русский и поставился в главный. Помогло загрузиться с LiveCD и поправить /etc/sysconfig/keyboard

Alexoy ()
Ответ на: комментарий от Alexoy

> Пожже уже прочитал, что в LXDE с этим проблемно.

Ничего проблемного. Создоть файл ~/.config/lxsession/LXDE/autostart и прописать в него что-то вроде

setxkbmap -layout «us,ru» -option «grp:menu_toggle,grp_led:scroll»

alpha ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.