LINUX.ORG.RU

установка пекета в debian


0

1

Добрый день У меня в debian вылезла циклическая зависимость 3 пакетов. Я их скачал но dpkg -i отказывается ставить их, т.к. тоже проверяет зависимости, а можно отключить их проверку?

Спасибо.


dpkg -i пакет1.deb пакет2.deb пакет3.deb

AITap ★★★★★ ()

Зачем вы скачиваете отдельно пакеты, вы должны ставить пакеты из репозитория вашего дистрибутива, с помощью пакетного менеджера apt, aptitude или synaptic.

kostik87 ★★★★★ ()

dpkg -i * в папке, где лежать только эти пакеты

pyometra ★★★★★ ()
Ответ на: комментарий от yirk

multiarch зависит от libdb5.1 и наоборот apt-get мне и пишет что один не может поставить без дркгого dependency cycle так сказать товарищи)))

ekso ()
Ответ на: комментарий от ekso

А зачем тебе крутой форум, если ты не в состоянии прочесть описание разделов и отличить Desktop от General?

Xellos ★★★★★ ()

Давно ли нерешенные зависимости стали помехой для dpkg? Сколько пользовался - всегда ставил, а потом запускал аптитуду - посмотреть, не сломались ли зависимости.

si0 ★★★ ()
Ответ на: комментарий от si0

>Давно ли нерешенные зависимости стали помехой для dpkg? Сколько пользовался - всегда ставил, а потом запускал аптитуду - посмотреть, не сломались ли зависимости.

А зачем такой дзен? Почему бы сразу через aptitude всё не ставить?

eugeno ★★★★★ ()
Ответ на: комментарий от eugeno

А зачем такой дзен? Почему бы сразу через aptitude всё не ставить?

Естественно, это не стандартный юзкейс. Иногда, например, надо откатиться на версию, которой уже нет в репах, но которая лежит в кеше.

si0 ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.