LINUX.ORG.RU

Sylpheed-Claws


0

0

Подскажите как можно собрать subj для GTK2 ? У меня стоит 0.9.12 ... По функционалу мне это клиент нравится, но вот виглядить оно - не ахти (потому как использует GTK+ 1.2)

Ответ на: Re: Re: Re: Sylpheed-Claws от Demetrio

Re: Re: Re: Re: Sylpheed-Claws

Там в исходниках был один глюк когда выставлено автоматическое определение кодировки... в той, что стояла у меня, в исходниках я поправил (там три строки) и все работало корректно...

Сейчас я поставил sylpheed-gtk2-0.9.12_20040622-i486-2mht.tgz (с указанного URL) и этот глюк опять проявился.

File - src/codeconv.c
< if (!cur_locale || strlen(cur_locale) == 0) cur_locale = g_getenv("LC_CTYPE");

< if (!cur_locale || strlen(cur_locale) == 0) cur_locale = g_getenv("LANG");
< if (!cur_locale || strlen(cur_locale) == 0) cur_locale = setlocale(LC_CTYPE, NULL);
---
> if (!cur_locale) cur_locale = g_getenv("LC_CTYPE");
> if (!cur_locale) cur_locale = g_getenv("LANG");
> if (!cur_locale) cur_locale = setlocale(LC_CTYPE, NULL);

daemon73 ★★ ()
Ответ на: Re: Re: Re: Re: Re: Re: Sylpheed-Claws от Demetrio

Re: Re: Re: Re: Re: Re: Re: Sylpheed-Claws

Оно самое... Поправил, пересобрал и все работает Осталось только плагины потцепить... но это уже другая история

daemon73 ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.