LINUX.ORG.RU

Барахлит апач.


0

1

Две проблемы, связанные с апачем:

1) Не получается настроить корневой путь:

<VirtualHost 127.0.0.1:80>
#ServerAdmin ...
ServerName test.ru
DocumentRoot «/var/www/»
<Directory «/var/www/test.ru»>
AllowOverride None
Order Allow,Deny
Allow from all
Options +Indexes +ExecCGI
</Directory>
ErrorLog /var/log/apache2/error_test.ru.log
DirectoryIndex index.html
#Allow from all
CustomLog /var/log/apache2/access_test.ru.log common
</VirtualHost>

Index.html он видит, а css и все, что читается от корня ищет не там:

[Thu May 05 14:14:43 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/
[Thu May 05 14:14:43 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/favicon.ico
[Thu May 05 14:14:43 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/favicon.ico
[Thu May 05 14:14:47 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/style.css, referer: http://localhost/test.ru/
[Thu May 05 14:14:47 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/res, referer: http://localhost/test.ru/
[Thu May 05 14:14:47 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/res, referer: http://localhost/test.ru/
[Thu May 05 14:14:47 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/res, referer: http://localhost/test.ru/
[Thu May 05 14:14:47 2011] [error] [client 127.0.0.1] client denied by server configuration: /var/www/res, referer: http://localhost/test.ru/

2) Если скопировать нужные файлы туда, куда он хочет, появляется другая фичебага - есть выпадающее меню, в нем шифка с анимацией. В первый раз менюшка выпадает, анимация проигрывается. Второй раз выпадает, а анимация не проигрывается, показывается только первый кадр. Под оффтопиком\денвером таких проблем не было.

3) Как сделать так, чтобы в адресной строке писать не http://localhost/test.ru, а http://test.ru

P.S. Gentoo, Gnome.

В первый раз менюшка выпадает, анимация проигрывается. Второй раз выпадает, а анимация не проигрывается, показывается только первый кадр. Под оффтопиком\денвером таких проблем не было.

Ты так шутишь, да?

все, что читается от корня

Строчку из html'я со ссылкой на css покажи.

thesis ★★★★★ ()

>Барахлит апач

будь мужиком - постучи молотком

visual_pipe ()
Ответ на: комментарий от thesis

Нет, не шучу. Именно так все и происходит. Причем, если взять настоящий сервак и туда все это по фтп залить, то все проигрывается, как должно быть.
<link rel=stylesheet href=/style.css type=«text/css»>

AlexCones ★★★ ()
Ответ на: комментарий от AlexCones

Ты ссылаешься на style.css, лежащий в корне. Апач ищет файл style.css в корне, то есть, в DocumentRoot. Что тебя удивляет?

Про анимацию все равно не смешно.

thesis ★★★★★ ()
Ответ на: комментарий от AlexCones

[Thu May 05 14:58:13 2011] [error] [client 127.0.0.1] File does not exist: /var/www/test.ru/test.ru

AlexCones ★★★ ()
Ответ на: комментарий от AlexCones

А вот скажи мне лучше, если ты скачал прон wget'ом с китайского сервера, просмотрел его один раз полностью, а во второй раз он зависает при просмотре на первом кадре, кто виноват - китайский сервер или wget?

thesis ★★★★★ ()
Ответ на: комментарий от thesis

Ключевое слово - на настоящем (не виртуальном) сервере все работает как надо + под денвером тоже. Кто виноват? Сто раз проверенная гифка или криво настроенный апач?

AlexCones ★★★ ()
Ответ на: комментарий от thesis

Вашу ****, причем здесь троллинг? Стоит проблема, которая не появляется под другими вирт и настоящими серверами.

AlexCones ★★★ ()
Ответ на: комментарий от AlexCones

>Стоит проблема, которая не появляется под другими вирт и настоящими серверами.

и которую никто до тебя никогда не встречал. Слушай, может еще раз внятно перепроверишь конфиги апача/кэш браузера, прежде чем утверждать о появившемся баге?

К слову, ты не поверишь, но Денвер, о котором ты упоминал, в качестве веб-сервера использует тот же самый пресловутый апач

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

>>>и которую никто до тебя никогда не встречал.

К слову, встречали,

При первой загрузке все нормально работает(нравится),а вот если убрать курсор

и заново навести gif не работает.Если это исправите, то будет отлично, а так...



Ссыль на пост дам при первом же требовании.

Чистка кеша, смена браузера ни к чему не приводят. К слову, сейчас все не работает - 404, сразу, между прочим, как только перезагрузил страницу. Конфиги не менял.


---

P.S. Странный баг наблюдается на ЛОРе - при нажатии любой клавиши идет переход на страницу назад. Приходится набирать все в gedit и копировать мышью. На других сайтах все нормально.

AlexCones ★★★ ()

P.S. Gentoo, Gnome.

>P.S. Gentoo, Gnome.

Во первых для апача пофиг и гента и гноме!

во вторых читаем настройки апача! - 100500 тысяч манов по настройке его!

ipwww ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.