LINUX.ORG.RU
ФорумAdmin

Виртуальные хосты апач

 , ,


0

2

В /etc/apache2/httpd.conf

NameVirtualHost *:80
ServerName localhost

 <VirtualHost *:80>
     ServerName    site.local
     DocumentRoot    /var/www/site/site/trunk/web/
 </VirtualHost>


<Directory /var/www>
     Options +ExecCGI
     AddHandler cgi-script .tcl .cgi
</Directory>


<Directory /var/www/site/site/trunk/web>
     AllowOverride All
</Directory>

Получаю стабильно «apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName»

Что за хрень? Ответ не гуглится так как в гугле все завалено советами задать имя основного хоста. А это чо - ServerName localhost, ля? Причем на десктопе такая конфа работает на ура. Оттуда файл и скопировал собственно.

Перемещено tazhate из web-development

Кстати, нашел такое решение - прописать в /etc/apache2/conf.d/vhosts.conf :

ServerName localhost
Варнинги кончились, но так и не заработало. А на десктопе и /etc/apache2/conf.d/vhosts.conf вообще нет и варнингов нет и все работает.

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

Вообщем выяснилось что он вообще не смотрит в /etc/apache2/httpd.conf :

# apachectl -S -k graceful
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server localhost (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost localhost (/etc/apache2/sites-enabled/000-default:1)
Syntax OK
Чо за фигня?

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

Уже настроил и через /etc/apache2/conf.d/vhosts.conf и через/etc/apache2/sites-enabled и он их даже видит:

apachectl -S -k graceful
[Mon May 06 11:07:21 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server site.local (/etc/apache2/conf.d/vhosts.conf:5)
         port 80 namevhost site.local (/etc/apache2/conf.d/vhosts.conf:5)
         port 80 namevhost localhost (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost site.local (/etc/apache2/sites-enabled/site.local:1)
Syntax OK

Но site.local упорно ведет в /var/www

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

Вобщем выходит что оно игнорирует напрочь параметр DocumentRoot.

httpd.conf оно не видит. DocumentRoot оно не видит. Чем бы его перее..?

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

этот ворнинг действительно ни на что не влияет

xtraeft ★★☆☆ ()
Ответ на: комментарий от gruy

Ubutnu 13.04

Как точно не покажу. Только если вечером, потому что забил и добавил этот сайт на большой машине. Просто с ней по ssh через GPRS трудится приходится. Ну да и пофиг.

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

почему бы не попробовать использовать apache2.conf?

xtraeft ★★☆☆ ()
Ответ на: комментарий от Suntechnic

Тогда все должно быть просто: создаешь файл с конфигом виртуального хоста в sites-available, настраиваешь в нем все для этого сайта, потом создаешь ссылку на него в sites-enabled (командой a2ensite your-config) и перезапускаешь сервер.

gruy ★★★★★ ()

В дебиане/убунте вхосты надо создавать отдельными конфигами в /etc/apache2/sites-enabled.

Там же у тебя лежит дефолтный виртуалхост, который тебе и мешает.

tazhate ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.