LINUX.ORG.RU

Eclipse и 64 битная ос


0

1

Возникла проблема с попыткой программирования для Android.
При попытке создания приложения, выдаёт вот эту ошибку.

[2011-03-02 08:02:57 - adb]/usr/local/Mobile/Android/android-sdk/platform-tools/adb: error while loading shared libraries: libncurses.so.5: wrong ELF class: ELFCLASS64
[2011-03-02 08:02:57 - adb]'adb version' failed! /usr/local/Mobile/Android/android-sdk/platform-tools/adb: error while loading shared libraries: libncurses.so.5: wrong ELF class: ELFCLASS64
[2011-03-02 08:02:57 - adb]Failed to parse the output of 'adb version'


http://s007.radikal.ru/i300/1103/6e/4b257cd3597a.png
libncurses.so.5 - у меня лежит в папке /lib64 куда его положить чтоб исправить ошибки?
и ещё вот, информация о моей системе
Linux localhost 2.6.36.2-desktop-2mnb #1 SMP Wed Dec 22 16:47:21 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Deleted

Ответ на: комментарий от madgnu

Когда пытаюсь через постановщик программ, установить libncurses5 для 32-х битной системы, пишет что «Невозможно выбрать данный пакет» =) ..как поправить?

Deleted ()
Ответ на: комментарий от Deleted

В системных требованиях к андроид-сдк ясно сказано, что на 64-битной Линукс-системе необходима возможность запуска 32-битных программ, потому как сам сдк 32-битный.

План действий:
1. удалить андроид-сдк;
2. выяснить, как в вашем дистрибутиве реализуется возможность запуска 32-битных программ. В дебиане/убунте для этого есть специальный пакет с набором 32-битных библиотек (ia32-libs). Возможно, в мандриве аналогично;
3. выполнить шаги, определенные в п.2;
4. установить андроид-сдк;
5. отчитаться в данной ветке о достигнутых результатах.

Ecl ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.