LINUX.ORG.RU

Пакеты и зависимости между ними


0

0

Добрый день.

Mandrake 10 / Gnome

После установки Linux понял, что поставил слишком много и кое-что можно удалить ;) Но почему то при попытке удаления некоторых пакетов, Linux говорит, что придется удалить другие, причем на мой взгляд абсолютно не связанные. Например - хочу удалить пакет sane-backends-1.0.13-6mdk (local and remote scanner access) - не дает, говорит, что придется увалить другие проекты - в том числе harddrake-ui-10-21mdk. То есть, если я удалю пакет отвечающий за сканеры у меня утилита настройки работать перестанет ?

Заранее благодарен.

Re: Пакеты и зависимости между ними

Чтобы тебе не мучится, переустанови все заново. И выбирай только самые необходимые пакеты. Причем для работы одних программ, необходимы другие пакеты. Боятся нечего.
Удачи ;-)

ALExorON ()

Re: Пакеты и зависимости между ними

А ты удали, указав параметр --nodeps. Тогда зависимости проверяться не будут. Скорее всего, все будет ОК. Ну не будет - поставишь пакет обратно.

anonymous ()
Ответ на: Re: Пакеты и зависимости между ними от anonymous

Пакеты и зависимости между ними

Подозреваю, что однажды так что-то удалив, я не смогу загрузиться ;)

То есть, ты хочешь сказать, что эти зависимоси могут быть прописаны с ошибками ? То есть - система говорит, что пакет ей нужен, а на самом деле он вовсе и не необходим ?

linuxBeginner ()
Ответ на: Пакеты и зависимости между ними от linuxBeginner

Re: Пакеты и зависимости между ними

ну не сказать чтоб с ошибками но через жопу - да, процент бардака зависит от дистрибутива. В твоем случае - посчитали что harddrake может конфигурить и сканеры (мол если их не будет то что я конфигурить буду?)

Радикальный способ - nodeps, способ по уму - качать *.src.rpm редактировать spec исправляя зависимости и делать rpmbuild -ba file.spec. Мне лично так сделать лень.

hooj ★★ ()

Re: Пакеты и зависимости между ними

Не слушай анонима (*) (01.04.2004 12:13:03) ;)

Не используй --no-deps если *ТОЧНО* не знаешь для чего нужна зависимость, а лучше вообще не используй.

Если не хочешь ничего лишнего, поставь минимальную установку, а потом ставь остальное по мере необходимости через apt/yum

slain ()
Ответ на: Re: Пакеты и зависимости между ними от slain

Re: Re: Пакеты и зависимости между ними

точно но-депс не используй..
лучше переустанови всё заного.. или забей хуй и оставь всё как есть, недумаю что эти пакеты критично места у тебя на винте занимают.. но лучше конечно переустанови, если линукс серьезно юзать/изучать собрался :)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.