LINUX.ORG.RU

GlobalMenuXFCE постоянно падает! Неужели никто не может починить?


0

0

Народ, работаю на Zenwalk-snapshot на нетбуке Samsung NC-10. Поставил из сырцов gobalmenu, так эта сволочь падает по пять раз в день, постоянно приходится заново добавлять плагин впанель. Писал в issues на сайте разработчика, но у него там прямо сказано, что этот плагин им больше не поддерживается, типа только gnome. Ну неужели одну ошибку никто не может починить? Я даже готов лично отблагодарить того, что это сделает, ибо штука для меня удобная, а аналогов нет. Я сам в программировании не силён.

Ссылка на пост в issues:
http://code.google.com/p/gnome2-globalmenu/issues/detail?id=604&sort=-id

Вот что пишет в логах:
.....lots of debug output....
(Thunar:5365): GLib-GObject-CRITICAL **: g_object_ref: assertion
`object->ref_count > 0' failed
(GlobalMenu.XFCEPlugin:5373): GlobalMenu:Server-DEBUG: window.vala:144:
window (0x822cd18) prop menu context is reported changed
The program 'GlobalMenu.XFCEPlugin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 13672 error_code 3 request_code 20 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
libxfce4panel-Message: Модуль глобального меню для панели XFCE: screen
changed: 0

libxfce4panel-Message: No valid plug window.

(xfce4-panel:5366): Gtk-CRITICAL **: gtk_socket_get_id: assertion
`GTK_WIDGET_ANCHORED (socket)' failed

(xfce4-panel:5366): libxfce4panel-CRITICAL **: Элемент был неожиданно
удалён: «Модуль глобального меню для панели XFCE».


То же при включении опции --sync:

(GlobalMenu.XFCEPlugin:4511): GlobalMenu:Server-DEBUG: monitor.vala:198: 0x92f2858,
update_active_window called once
The program 'GlobalMenu.XFCEPlugin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 20815 error_code 3 request_code 20 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
libxfce4panel-Message: Модуль глобального меню для панели XFCE: screen changed: 0

libxfce4panel-Message: No valid plug window.

(xfce4-panel:4443): Gtk-CRITICAL **: gtk_socket_get_id: assertion
`GTK_WIDGET_ANCHORED (socket)' failed

(xfce4-panel:4443): libxfce4panel-CRITICAL **: Элемент был неожиданно удалён: «Модуль
глобального меню для панели XFCE».


Падает, я так понял, при открытии-закрытии каких-то окон.
Есть идели?

★★★

> но у него там прямо сказано, что этот плагин им больше не поддерживается, типа только gnome

и ты хочешь, чтоб лоровцевы починили вместо него? попытайся поставить предыдущие версии

anonymous ()

пересобери из сырцов с поддержкой gdb если там такая есть и попробуй поймать ошибку.

splinter ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.