LINUX.ORG.RU

изменить разрешение в ubuntu 10.04


0

0

Не могу изменить разрешение в ubuntu 10.04 на оптимальное для монитора (1280х1024). Когда захожу в настройки монитора появляется сообщение о том что драйвера на монитор не найдены и параметры будут изменены с помощью драйвера видеокарты. Если там выставить через advanced это разрешение то на экране не помещается весь рабочий стол и приходится прокручивать вниз и вправо. монитор: Acer AL1916. Драйверов под Линукс на него не смог найти.


драйверы на монитор? о_О
Попробуй прямо к xorg.conf прописать разрешение, это же вроде там делается.

Zhbert ★★★★★ ()

sudo gedit /etc/X11/xorg.conf

и приводишь его к такому виду

Section "Monitor"
	Identifier   "Default monitor"
EndSection

Section "Device"
	Identifier  "Default card"
	VendorName  "nVidia Corporation"
	BoardName   "G92 [GeForce 9600 GT]"
	BusID       "PCI:1:0:0"
	Driver      "nvidia"
	Option      "NoLogo"    "1"
	Option      "Coolbits"	"1"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Default card"
	Monitor    "Default monitor"
	SubSection "Display"
        	Viewport 0 0
        	Depth 32
        	Modes "1280x1024" "1024x768" "800x600"
	EndSubSection
EndSection

это для nvidia. У ati будут другие параметры в Section «Device»

JB ★★★★★ ()

Если там выставить через advanced это разрешение то на экране не помещается весь рабочий стол и приходится прокручивать вниз и вправо

А вы уверены, в таком случае, что выставляете его родное разрешение? ЖК-мониторы не умеют сжимать изображение большего разрешения, чем максимально поддерживаемое ими и, если его выставить, ведут себя именно так.

Axon ★★★★★ ()

Оказалось что если удалить xorg.conf то после перезагрузки разрешение автоматически стаёт 1280х1024. Но слетают драйвера на видеокарту. При входе в настройки nvidia появляется сообщение о том, что нужно прописать nvidia-xconfig. Но если прописать эту команду то разрешение опять устанавливается в 1024х768 и на 1280х1024 поменять нельзя. Видеокарта AGP GeForce 6600. Может что-то с драйверами?

agert ()
Ответ на: комментарий от agert

я тебе уже сказал - приведи xorg.conf к такому же виду как у меня

JB ★★★★★ ()
Ответ на: комментарий от agert

В терминале сделай gtf 1280 1024 60 и вывод добавь в Section «Monitor» xorg.conf'a

Типа:
Section «Monitor»
   Identifier «Left»
   ModeLine «1280x1024_60.00» 108.9 1280 1360 1496 1712 1024 1025 1028 1060 -hsync +vsync
   Option    «PreferredMode» «1280x1024_60.00»
EndSection

amorpher ★★★★★ ()
Ответ на: комментарий от agert

>gtf 1280 1024 60

Ну может не 60, а сколько надо (если ЭЛТ), 75 или 80 к примеру, поэкспереминтируй и максимум оставь. Для ЖК - 60, больше не надо.

amorpher ★★★★★ ()
Ответ на: комментарий от JB

>я тебе уже сказал - приведи xorg.conf к такому же виду как у меня

пробовал не помогает

agert ()
Ответ на: комментарий от Axon

>ЖК-мониторы не умеют сжимать изображение большего разрешения, чем максимально поддерживаемое ими и, если его выставить, ведут себя именно так.
Что за бред сивой кобылы?

anotheranonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.